Program3_A

 我现在做的是第三专题编号为1001的试题, 具体内容如下所示:

Problem A

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 182   Accepted Submission(s) : 30
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.<br>
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).<br>
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.<br>
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
简单题意:

在组成环的n个数中求出不超过m个连续的数相加之和最大时的最大值、起始位置和终止位置(如果大于n则要减去n)

解题思路:

设一数组sum,sum[i]含义:所有以a[i]为结尾的序列的序列和构成一个集合,此集合的最大值就是sum[i]
如1,2,3.所有以a[2]=3为结尾的序列的序列和集合是{6,5,3},因而sum[2]=6.
sum的状态转移方程:sum[i] = max{sum[i-1]+a[i], a[i]}
ans必定是sum[0···(k-1)]之一。由于要记录起始位置和结束位置,引入s数组记录获得sum的序列的起始元素的位置,而由sum的定义,sum[i]的结束位置是i不用另外记录。

#include <cstdio>

using namespace std;

int a[100005], sum[100005], s[100005];

int main()
 {
     int T, N;
     int ca = 0, ans;
          scanf("%d", &T);
     while(ca < T)
     {
         scanf("%d", &N);
         for(int i = 0; i < N; i++)
             scanf("%d", &a[i]);
         ans = 0;
         sum[0] = a[0];
         s[0] = 0;
         for(int i = 1; i < N; i++)
         {
             if(sum[i-1] >= 0)
             {
                 sum[i] = sum[i-1] + a[i];
                 s[i] = s[i-1];
             }

             else
             {
                 sum[i] = a[i];
                 s[i] = i;
             }
             if(sum[ans] < sum[i])
                ans = i;
         }
         printf("Case %d:\n%d %d %d\n", ++ca, sum[ans], s[ans] + 1, ans + 1);

         if(ca != T) puts("");
     }
     return 0;
 }

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值