Program3_Q

 我现在做的是第三专题编号为1017的试题,具体内容如下所示:

 

Problem Q

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 41   Accepted Submission(s) : 16
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …<br>The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?<br><center><img src=../../../data/images/C154-1003-1.jpg> </center><br>
 

Input
The first line contain a integer T , the number of cases.<br>Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2<sup>31</sup>).
 

Sample Input
  
  
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
  
  
14

简单题意:

第一行输入几组数据,第二行第一个数字代表物体个数,第二个数代表总体积 第三行输入的是物品的价值,第四行输入的是物品的体积。物体不能拆分,已知背包的总体积,求最大能获取的价值是多少。

解题思路:

将前i件物品放入容量为v的背包中”这个子问题,若只考虑第i件物品的策略(放或不放),那么就可以转化为一个只牵扯前i-1件物品的问题。如果不放第i件物品,那么问题就转化为“前i-1件物品放入容量为v的背包中”,价值为f[j-c[i]];如果放第i件物品,那么问题就转化为“前i-1件物品放入剩下的容量为v-c[i]的背包中”,此时能获得的最大价值就是f[j-c[i]]再加上通过放入第i件物品获得的价值w[i]

编写代码:

 #include <stdio.h>

#include <string.h>

int f[1000],c[1000],w[1000];

int main()
{
   int t,n,v;
   scanf("%d",&t);
   while (t--)
   {
         memset(f,0,sizeof(f));
         scanf("%d%d",&n,&v);
         for (int i=1;i<=n;i++)
             scanf("%d",&w[i]);
         for (int i=1;i<=n;i++)
             scanf("%d",&c[i]);
         for (int i=1;i<=n;i++)
            for (int j=v;j>=c[i];j--)
                 if (f[j-c[i]]+w[i]>f[j])
                      f[j]=f[j-c[i]]+w[i];
         printf("%d\n",f[v]);
     }
    return 0;
 }

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值