ACM Program A

 我现在做的是ACM编号为1000的试题,题意如下:

Problem A

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 316   Accepted Submission(s) : 39
Problem Description
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
 

Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
 

Output
The output should contain the minimum time in minutes to complete the moving, one per line.
 

Sample Input
  
  
3 4 10 20 30 40 50 60 70 80 2 1 3 2 200 3 10 100 20 80 30 50
 

Sample Output
  
  
10 20 30


简单题意:两排房间之间有个走廊,但很窄,只能通过一个桌子,所以在搬的时候所要经过的路段要保证只有他这一组,只要不是同一段走廊,都可以在房间之间移动桌子。

解题思路:先按照移动的开始房间的编号进行排序,有的房间是对门,这样,要把它看成一个房间,所以,通过这个语句,即 房间编号 = 房间编号 + (房间编号 % 2) ,来重新设置编号,排好序后,从第一个房间来计算,如果第一个的结束编号比下一个的开始编号小,就不妨碍下一次的移动,通过计算来统计一次没有障碍能移动几次,判断还没有移动多少,再运行一次,看能通过多少,直到全部通过。

编写代码:

#include <iostream>
#include <algorithm>
using namespace std;
struct stick{
   int length;
   int weight;
 };


 bool cmp(stick a, stick b)
 {
     if (a.length == b.length)
        return a.weight < b.weight;
     else
        return a.length < b.length;
 }
int main()
{
    stick a[5000];
    int b[5000];
    int n;
    cin >> n;
    while (n != 0)
    {
        int t, group;
        cin >> t;
        for (int i=0; i<t; i++)
        {
            cin >> a[i].length >> a[i].weight;
        }
        sort(a, a+t, cmp);
        b[0] = 1;
        for (int i=1; i<t; i++)
        {
            group = 0;
            for (int j=0; j<i; j++)
                if(a[i].weight < a[j].weight && group < b[j])
                   group = b[j];
            b[i] = group + 1;
        }
        int minute = 0;
        for (int i=0; i<t; i++)
            if (b[i] > minute)
                minute = b[i];
        cout << minute << endl;
        n--;
    }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值