hdu2476(区间DP)

地址:http://acm.hdu.edu.cn/showproblem.php?pid=2476

String painter

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1466    Accepted Submission(s): 632


Problem Description
There are two strings A and B with equal length. Both strings are made up of lower case letters. Now you have a powerful string painter. With the help of the painter, you can change a segment of characters of a string to any other character you want. That is, after using the painter, the segment is made up of only one kind of character. Now your task is to change A to B using string painter. What’s the minimum number of operations?
 

Input
Input contains multiple cases. Each case consists of two lines:
The first line contains string A.
The second line contains string B.
The length of both strings will not be greater than 100.
 

Output
A single line contains one integer representing the answer.
 

Sample Input
  
  
zzzzzfzzzzz abcdefedcba abababababab cdcdcdcdcdcd
 

Sample Output
  
  
6 7
 

题意:刷油漆,最小刷多少次使得第一个串变成第二个串。

思路:本来准备开三维数组,因为题上说输入的只有小写字母,其次刷完后要记录。准备写时朋友给我说了种方法,就是先将一个空白串刷成第二个串,得到最小的刷法并打成DP表,然后再将第一个串刷成第二个串,引用刚才打的DP表。

代码:

#include<iostream>
#include<queue>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
#define LL __int64
#define Mod 1000000007
char a[110],b[110];
int dp[110][110];
int main(){
    while(gets(a)>0){
        gets(b);
        int len=strlen(a);
        for(int i=0;i<len;i++) dp[i][i]=1;  //空白串,全打成1
        for(int l=1;l<len;l++){
            for(int i=0;i<len-l;i++){
                int j=i+l;
                dp[i][j]=j-i+1;
                for(int k=i+1;k<=j;k++){
                    if(b[i]==b[k]) dp[i][j]=min(dp[i][j],dp[i][k-1]+dp[k+1][j]);
                    dp[i][j]=min(dp[i][j],dp[i][k-1]+dp[k][j]);
                }
            }
        }
        for(int i=0;i<len;i++){  //第一串,相同为0,不同为1
            if(a[i]==b[i]) dp[i][i]=0;
            else dp[i][i]=1;
        }
        for(int l=1;l<len;l++){
            for(int i=0;i<len-l;i++){
                int j=i+l;
                for(int k=i;k<=j;k++){
                    if(a[k]==b[k]) dp[i][j]=min(dp[i][j],dp[i][k-1]+dp[k+1][j]);
                }
            }
        }
        printf("%d\n",dp[0][len-1]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值