Open the Lock
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 2897 Accepted Submission(s): 1263
Problem Description
Now an emergent task for you is to open a password lock. The password is consisted of four digits. Each digit is numbered from 1 to 9.
Each time, you can add or minus 1 to any digit. When add 1 to '9', the digit will change to be '1' and when minus 1 to '1', the digit will change to be '9'. You can also exchange the digit with its neighbor. Each action will take one step.
Now your task is to use minimal steps to open the lock.
Note: The leftmost digit is not the neighbor of the rightmost digit.
Each time, you can add or minus 1 to any digit. When add 1 to '9', the digit will change to be '1' and when minus 1 to '1', the digit will change to be '9'. You can also exchange the digit with its neighbor. Each action will take one step.
Now your task is to use minimal steps to open the lock.
Note: The leftmost digit is not the neighbor of the rightmost digit.
Input
The input file begins with an integer T, indicating the number of test cases.
Each test case begins with a four digit N, indicating the initial state of the password lock. Then followed a line with anotther four dight M, indicating the password which can open the lock. There is one blank line after each test case.
Each test case begins with a four digit N, indicating the initial state of the password lock. Then followed a line with anotther four dight M, indicating the password which can open the lock. There is one blank line after each test case.
Output
For each test case, print the minimal steps in one line.
Sample Input
2 1234 2144 1111 9999
Sample Output
2 4
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
int getnum[10][10][10][10];
struct node
{
char s[10];
int step;
}s1,s2;
void bfs() //这样的bfs当第一次遇到可以解锁的密码时,就可以直接跳出,也就是最少步骤时
{
queue<node> qi;
qi.push(s1);
char l;
node k;
int i;
while(!qi.empty())
{
s1=qi.front();
qi.pop();
if(!strcmp(s1.s,s2.s))
{
printf("%d\n",s1.step);
break;
}
for(i=0;i<4;i++) //+1的处理
{
k=s1;
if(k.s[i]=='9') k.s[i]='1';
else k.s[i]++;
if(!getnum[k.s[0]-'0'][k.s[1]-'0'][k.s[2]-'0'][k.s[3]-'0'])
{
getnum[k.s[0]-'0'][k.s[1]-'0'][k.s[2]-'0'][k.s[3]-'0']=1;
k.step=s1.step+1;
qi.push(k);
}
}
for(i=0;i<4;i++) //-1的处理
{
k=s1;
if(k.s[i]=='1') k.s[i]='9';
else k.s[i]--;
if(!getnum[k.s[0]-'0'][k.s[1]-'0'][k.s[2]-'0'][k.s[3]-'0'])
{
getnum[k.s[0]-'0'][k.s[1]-'0'][k.s[2]-'0'][k.s[3]-'0']=1;
k.step=s1.step+1;
qi.push(k);
}
}
for(i=0;i<3;i++) //交换的处理
{
k=s1;
l=k.s[i];k.s[i]=k.s[i+1];k.s[i+1]=l;
if(!getnum[k.s[0]-'0'][k.s[1]-'0'][k.s[2]-'0'][k.s[3]-'0'])
{
getnum[k.s[0]-'0'][k.s[1]-'0'][k.s[2]-'0'][k.s[3]-'0']=1;
k.step=s1.step+1;
qi.push(k);
}
}
}
}
int main()
{
int t;
scanf("%d",&t);
getchar();
while(t--)
{
scanf("%s",s1.s);
s1.step=0;
scanf("%s",s2.s);
s2.step=100;
memset(getnum,0,sizeof(getnum));
bfs();
}
return 0;
}
按照要求进行广搜,不用多考虑。当第一次得出可以解锁的密码时,就可以跳出输出结果。这里用广搜的好处就是有这种效果,第一个得到的结果就是最优结果,而深搜第一次的到的结果不一定是最优的。