Open the Lock hdu 1195 BFS 与hdu2717惊人的相似

Open the Lock

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3281    Accepted Submission(s): 1454


Problem Description
Now an emergent task for you is to open a password lock. The password is consisted of four digits. Each digit is numbered from 1 to 9.  
Each time, you can add or minus 1 to any digit. When add 1 to '9', the digit will change to be '1' and when minus 1 to '1', the digit will change to be '9'. You can also exchange the digit with its neighbor. Each action will take one step.

Now your task is to use minimal steps to open the lock.

Note: The leftmost digit is not the neighbor of the rightmost digit.
 

Input
The input file begins with an integer T, indicating the number of test cases.  

Each test case begins with a four digit N, indicating the initial state of the password lock. Then followed a line with anotther four dight M, indicating the password which can open the lock. There is one blank line after each test case.
 

Output
For each test case, print the minimal steps in one line.
 

Sample Input
  
  
2 1234 2144 1111 9999
 

Sample Output
  
  
2 4
 

Author
YE, Kai
 
 
 
   
 
 
这个题目的意思是说,最少几步可以求出换出密码,可以+1,可以-1,可以相邻的交换,但是要注意9+1=1,1-1=9,我们要以此求出最少的步数,说实话,我真是不知道这个题目可以用BFS来完成,但是我想想以前那个poj 3278 抓奶牛的问题,真是惊人的相似哎,我觉得可以形成这么一种思路,把所有的情况用BFS全部模拟到,取到最小的就是了,用flag,来表示是否符合,设置四个标志变量,和普通的方法有点出入,建议就是将hdu 2717与这个题目放一块做,好好领悟领悟!!!!!
 
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
struct node
{
    int num[4];
    int step;

};
node fis,la;
int visit[12][12][12][12];
void bfs()
{
    queue<node>q;
    int i,j;
    int flag;
    memset(visit,0,sizeof(visit));//表示变量
    fis.step=0;
    flag=1;
    visit[fis.num[0]][fis.num[1]][fis.num[2]][fis.num[3]]=1;
    node p;
    q.push(fis);
    while(!q.empty())
    {
     fis=q.front();
     q.pop();
     flag=1;
     for(i=0;i<4;i++)
     {
         if(fis.num[i]!=la.num[i])
         {
             flag=0;
             break;
         }

     }
     if(flag)
     {
        printf("%d\n",fis.step);
        return;
     }
     for(i=0;i<4;i++)//-1
     {
         p=fis;
         if(fis.num[i]==1)
         p.num[i]=9;
         else
         p.num[i]=fis.num[i]-1;
         p.step=fis.step+1;
         if(!visit[p.num[0]][p.num[1]][p.num[2]][p.num[3]])
         {

             visit[p.num[0]][p.num[1]][p.num[2]][p.num[3]]=1;
             q.push(p);

         }


     }
     for(i=0;i<4;i++)//+1
     {
         p=fis;
         if(fis.num[i]==9)
         p.num[i]=1;
         else
         p.num[i]=fis.num[i]+1;
         p.step=fis.step+1;
         if(!visit[p.num[0]][p.num[1]][p.num[2]][p.num[3]])
         {

             visit[p.num[0]][p.num[1]][p.num[2]][p.num[3]]=1;
             q.push(p);

         }


     }

    for(i=0;i<3;i++)//交换
    {
        p=fis;
        p.num[i]=fis.num[i+1];
        p.num[i+1]=fis.num[i];
        p.step=fis.step+1;
        if(!visit[p.num[0]][p.num[1]][p.num[2]][p.num[3]])
        {

             visit[p.num[0]][p.num[1]][p.num[2]][p.num[3]]=1;
             q.push(p);

        }

    }

    }

}
int main()
{


   int i,j,t;
   scanf("%d",&t);
   char a[5];
   char b[5];
   while(t--)
   {
       scanf("%s",a);
       scanf("%s",b);
       for(i=0;i<4;i++)
       fis.num[i]=a[i]-'0';
       for(i=0;i<4;i++)
       la.num[i]=b[i]-'0';
       bfs();
   }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值