POJ 3130 计算几何 java

How I Mathematician Wonder What You Are!

问题描述 :

After counting so many stars in the sky in his childhood, Isaac, now an astronomer and a mathematician uses a big astronomical telescope and lets his image processing program count stars. The hardest part of the program is to judge if shining object in the sky is really a star. As a mathematician, the only way he knows is to apply a mathematical definition of stars.

The mathematical definition of a star shape is as follows: A planar shape F is star-shaped if and only if there is a point C ∈ F such that, for any point P ∈ F, the line segment CP is contained in F. Such a point C is called a center of F. To get accustomed to the definition let’s see some examples below.

The first two are what you would normally call stars. According to the above definition, however, all shapes in the first row are star-shaped. The two in the second row are not. For each star shape, a center is indicated with a dot. Note that a star shape in general has infinitely many centers. Fore Example, for the third quadrangular shape, all points in it are centers.

Your job is to write a program that tells whether a given polygonal shape is star-shaped or not.

输入:

The input is a sequence of datasets followed by a line containing a single zero. Each dataset specifies a polygon, and is formatted as follows.

n 
x1y1
x2y2

xnyn

The first line is the number of vertices, n, which satisfies 4 ≤ n ≤ 50. Subsequent n lines are the x- and y-coordinates of the n vertices. They are integers and satisfy 0 ≤ xi ≤ 10000 and 0 ≤ yi ≤ 10000 (i = 1, …, n). Line segments (xi, yi)–(xi + 1, yi + 1) (i = 1, …, n − 1) and the line segment (xn, yn)–(x1, y1) form the border of the polygon in the counterclockwise order. That is, these line segments see the inside of the polygon in the left of their directions.

You may assume that the polygon is simple, that is, its border never crosses or touches itself. You may assume assume that no three edges of the polygon meet at a single point even when they are infinitely extended.

输出:

For each dataset, output “1” if the polygon is star-shaped and “0” otherwise. Each number must be in a separate line and the line should not contain any other characters.

样例输入:

6 
66 13 
96 61 
76 98 
13 94 
4 0 
45 68 
8 
27 21 
55 14 
93 12 
56 95 
15 48 
38 46 
51 65 
64 31 
0

样例输出:

1
0

import java.util.Scanner;  
  
public class Main {  
  
    static double x[], y[];  
    static double tx[], ty[];  
    static double txp[], typ[];  
    static int num;  
    static int tnum;  
    static double a, b, c;  
  
    public static void main(String[] args) {  
  
        Scanner scan = new Scanner(System.in);  
  
        while (true) {  
  
            int n = scan.nextInt();  
            if (n == 0)  
                break;  
            num = n;  
  
            x = new double[100];  
            y = new double[100];  
            tx = new double[100];  
            ty = new double[100];  
            txp = new double[100];  
            typ = new double[100];  
  
            for (int i = 0; i < n; i++) {  
                x[i] = scan.nextDouble();  
                y[i] = scan.nextDouble();  
                tx[i + 1] = x[i];  
                ty[i + 1] = y[i];  
            }  
  
            x[n] = x[0];  
            y[n] = y[0];  
            tx[0] = tx[n];  
            ty[0] = ty[n];  
            tx[n + 1] = tx[1];  
            ty[n + 1] = ty[1];  
  
            for (int i = 0; i < n; i++) {  
                a = y[i + 1] - y[i]; //求直线aX+bY+c=0的参数a,b,c   
                b = x[i] - x[i + 1];  
                c = x[i + 1] * y[i] - x[i] * y[i + 1];  
                solve();  
            }  
  
            if (num == 0)  
                System.out.println("0");  
            else  
                System.out.println("1");  
  
        }  
  
    }  
  
    public static void solve() {  
  
        tnum = 0;  
  
        for (int i = 1; i <= num; i++) {  
  
            if (sig(a * tx[i] + b * ty[i] + c) <= 0) {  // 在一侧   
                txp[tnum] = tx[i];  
                typ[tnum++] = ty[i];  
            } else {                                    // 在另一侧   
                if (sig(a * tx[i - 1] + b * ty[i - 1] + c) < 0)  //小于0才会有交点   
                    insert(tx[i - 1], ty[i - 1], tx[i], ty[i]);  
                if (sig(a * tx[i + 1] + b * ty[i + 1] + c )< 0)  
                    insert(tx[i + 1], ty[i + 1], tx[i], ty[i]);  
            }  
        }  
  
        num = tnum;                       //更新  num,tx,ty   
  
        for (int j = 1; j <= num; j++) {  
            tx[j] = txp[j - 1];  
            ty[j] = typ[j - 1];  
        }  
        tx[0] = tx[num];  
        ty[0] = ty[num];  
        tx[num + 1] = tx[1];  
        ty[num + 1] = ty[1];  
  
    }  
  
    private static int sig(double d) {  
        if(d< 1e-10)  
            return -1;  
        else if(d>1e-10)  
            return 1;  
        return 0;  
    }  
   //求两直线交点  其中一条直线  已经表示成ax+by+c=0,  另一直线 是两个点   
    public static void insert(double x1, double y1, double x2, double y2) { 
        double xx = Math.abs(a * x1 + b * y1 + c);  
        double yy = Math.abs(a * x2 + b * y2 + c);  
        txp[tnum] = (x1 * yy + x2 * xx) / (xx + yy);  
        typ[tnum++] = (y1 * yy + y2 * xx) / (xx + yy);  
  
    }  
  
}

来自: ACM之家

www.acmerblog.com



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值