poj1273 网络流 Dinic

Drainage Ditches
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 58914 Accepted: 22615

Description

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50

上一篇这题采用的是Edmonds_Karp算法,这次采用更高效的Dinic算法,Dinic算法是采用DFS对每一个层次网络进行多次增广。

关于复杂度分析:

在神犇王欣上的论文中,证明了一个定理:

对于有n个点的流量网络,在最短路径增值算法中,最多有n个阶段。

而每个阶段采用的是DFS多次增广,因为最多O(m)条边,每增广一次,就有一条关键边消失,因此最多增广O(m)次,每次增广沿一条增广路前进后退,而增广路最长为O(n)。

总复杂度为O(n^2*m)

代码:

#include<cstdio>
#include<iostream>
#include<cstring>
#define Maxn 210
using namespace std;

const int inf=0x3f3f3f3f;
struct line{
    int to,next,cap;
}p[Maxn<<1];
int head[Maxn];
int q[Maxn]; //BFS队列
int d[Maxn]; //层次
int tot;
int src,t; //源点,汇点
int n,m; //边,节点数
void addedge(int a,int b,int c){
    p[tot].to=b;
    p[tot].next=head[a];
    p[tot].cap=c;
    head[a]=tot++;
}
void insert(int a,int b,int c){
    addedge(a,b,c);
    addedge(b,a,0);
}
bool bfs(){
    memset(d,-1,sizeof d);
    int s=0,e=-1;
    q[++e]=src;
    d[src]=0;
    while(s<=e){
        int u=q[s++];
        for(int i=head[u];i!=-1;i=p[i].next){
            int v=p[i].to;
            if(d[v]==-1&&p[i].cap){
                d[v]=d[u]+1;
                q[++e]=v;
            }
        }
    }
    return d[t]!=-1;
}
int dfs(int u,int alpha){
    if(u==t) return alpha;
    int w,used=0;
    for(int i=head[u];i!=-1&&used<alpha;i=p[i].next){
        int v=p[i].to;
        if(p[i].cap&&d[v]==d[u]+1){
            w=dfs(v,min(alpha-used,p[i].cap));
            used+=w;
            p[i].cap-=w;
            p[i^1].cap+=w;
        }
    }
    if(!used) d[u]=-1;
    return used;
}
int dinic(){
    int ans=0;
    src=1,t=n; //初始化源点和汇点
    while(bfs())
        ans+=dfs(src,inf);
    return ans;
}
int main()
{
    int u,v,c;
    while(~scanf("%d%d",&m,&n)){
        tot=0;
        memset(head,-1,sizeof head);
        while(m--){
            scanf("%d%d%d",&u,&v,&c);
            insert(u,v,c);
        }
        printf("%d\n",dinic());
    }
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值