PAT-A1005 Spell It Right【大数处理】

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤10​100​​).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

代码太简单了,所以就不注释了。。。。 

#include <iostream>
#include <string>
#include <stack>
using namespace std;
int main(){
	string s;
	cin>>s;
	stack<int> res;
	int sum=0;
	int n=s.size();
	for(int i=0;i<n;i++){
		sum+=(int)s[i]-48;
	}                                     
	int yu;
	if(sum==0){
		cout<<"zero";
		return 0;
	}
	while(sum){
		yu=sum%10;
		res.push(yu);
		sum/=10;

	}
	int a=res.top();
	
	if(a==1){
		cout<<"one";
	}
	else if(a==2){
		cout<<"two";
	}
	else if(a==3){
		cout<<"three";
	}
	else if(a==4){
		cout<<"four";
	}
	else if(a==5){
		cout<<"five";
	}
	else if(a==6){
		cout<<"six";
	}
	else if(a==7){
		cout<<"seven";
	}
	else if(a==8){
		cout<<"eight";
	}
	else{
		cout<<"nine";
	}
	res.pop();

	while(!res.empty()){
		switch(res.top()){
			case 0:
			cout<<" "<<"zero";
			res.pop();
			break;
		case 1:
			cout<<" "<<"one";
			res.pop();
			break;
     	case 2:
			cout<<" "<<"two";
			res.pop();
			break;
		case 3:
			cout<<" "<<"three";
			res.pop();
			break;
		case 4:
			cout<<" "<<"four";
			res.pop();
			break;
		case 5:
			cout<<" "<<"five";
			res.pop();
			break;			
		case 6:
			cout<<" "<<"six";
			res.pop();
			break;
		case 7:
			cout<<" "<<"seven";
			res.pop();
			break;
		case 8:
			cout<<" "<<"eight";
			res.pop();
			break;
		case 9:
			cout<<" "<<"nine";
			res.pop();
			break;
		default:
			break;
		}
	}
	return 0;
}

有一个小问题,就是段错误。一般就是数组越界啦,栈/队列为空仍然pop()啦

这道题有一个极端的情况,就是单输入一个0,这样的话sum结果是0,无法进入while()循环而导致stack为空,这样在输出第一个数字的时候,就会发生段错误(54行的pop()引起)

 

冗长的一比。仔细观察代码主要是因为使用Switch进行了多次判断,我们可以使用一个answer字符串数组来做一个映射,即

0->"zer0"

1->"one"

2->"two"

下标为0内容为"zero",下标为1内容为"one。

精简之后

#include <iostream>
#include <string>
#include <stack>
using namespace std;
int main(){
	string s;
	string answer[10]={"zero","one","two","three","four","five","six","seven","eight","nine"};
	cin>>s;
	stack<int> res;
	int sum=0;
	int n=s.size();
	for(int i=0;i<n;i++){
		sum+=(int)s[i]-48;
	}                                     
	int yu;
	if(sum==0){
		cout<<"zero";
		return 0;
	}
	while(sum){
		yu=sum%10;
		res.push(yu);
		sum/=10;

	}
	int a=res.top();
	cout<<answer[a];
	res.pop();

	while(!res.empty()){
		cout<<" "<<answer[res.top()];
		res.pop();
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值