PAT-A1009 Product of Polynomials【多项式乘法】

PAT-1002多项式加法

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

基本思路,使用两个数组ploya,ployb分别存储两个多项式,一个ployre数组表示结果。数组下标代表幂,内容代表系数。

两个循环,外面循环遍历ploya,内面循环遍历ployb,两个下标相加之和是结果的下标,两个下标对应的值相乘的结果是ployre对应下标的值。


#include<stdio.h>
const int maxnum=1001;    //边界值的设定一定要找准,最大是1000,最小是0,最多1001个数
double ploya[maxnum]={0.0};
double ployb[maxnum]={0.0};
double ployre[2*maxnum]={0.0};
int main (){
	int numa,numb,a,max1,max2;
	double b;
	scanf("%d",&numa);
	for(int i=0;i<numa;i++){   //保存第一个数组
		scanf("%d",&a);
		if(i==0){
			max1=a;
		}
		scanf("%lf",&b);
		ploya[a]=b;
	}
	scanf("%d",&numb);
	for(int j=0;j<numb;j++){    //保存第二个数组

		scanf("%d",&a);
		if(j==0){
			max2=a;
		}
		scanf("%lf",&b);
		ployb[a]=b;
	}
	int numofre=0;              //纪录多项式的项数
	int e;
	int maxup=max1+max2;        //两个多项式相乘,结果的最高次幂等于两个多项式最高次幂之和
	int index;
	double mul;
	for(int d=0;d<=max1;d++){

		for(e=0;e<=max2;e++){
			index=d+e;            //下标之和为结果的下标
			mul=ploya[d]*ployb[e];
			ployre[index]+=mul;   //内容之积为结果的内容
		}
	}
	
	for(int g=0;g<=maxup;g++){    //遍历结果数组,找到不为零的项的个数
		if(ployre[g]!=0){
			numofre++;
		}
	}
	printf("%d",numofre);
	for(int f=maxup;f>=0;f--){
		if(ployre[f]!=0){
		printf(" %d %.1lf",f,ployre[f]);
		}
	}
	
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值