PAT-A1009 Product of Polynomials (多项式乘法)

A1009 Product of Polynomials (多项式乘法)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1 a**N1 N2 a**N2 … N**K aNK

where K is the number of nonzero terms in the polynomial, N**i and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N**K<⋯<N2<N1≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5
结尾无空行

Sample Output:

3 3 3.6 2 6.0 1 1.6

结尾无空行

题意:

一个test包含两行,每行各输入一个多项式,第一个数是代表该多项式的非零项数,接下来两个是该项的指数和系数,最后输出两个多项式的乘积的非零项数以及各项的指数和系数。

分析:

相信看过我上篇刷题笔记对多项式加法的童鞋应该很快就能做出这道题了吧!

(^_-)

这道题和多项式加法的题目差不多

  1. 新建一个double数组 double类型的 ploy[maxn]={}和ans[maxn]分别存储初始数组和计算后的数组,该数组的下标表示指数,下标对应的值表示系数。
  2. 接收输入的指数和系数的值,进行多项式的乘法计算。即:指数相加,系数相乘
  3. 遍历找出两多项式的非零项个数
  4. 遍历输出结果

注意点:此处多项式的乘法因为我们是用数组的下标来表示多项式的指数,所以这里的ans数组至少要开到1000*2

代码如下:

#include<cstdio>
const int maxn=2001;
int main(){
	double ploy[maxn]={};
	double ans[maxn]={};
	int k,z;
	double x;
	scanf("%d",&k);
	for(int i=0;i<k;i++){
		scanf("%d %lf",&z,&x);
		ploy[z]=x;
	}
	scanf("%d",&k);
	for(int i=0;i<k;i++){
		scanf("%d %lf",&z,&x);
		for(int j=0;j<maxn;j++){
			if(ploy[j]!=0) ans[j+z]+=ploy[j]*x;
		}
	}
	int count =0;
	for(int i=0;i<maxn;i++){
		if(ans[i]!=0) count++;
	}
	printf("%d",count);
	for(int i=maxn-1;i>=0;i--){
		if(ans[i]!=0) printf(" %d %.1f",i,ans[i]);
	}
	return 0;
}

OK,最后成功AC!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值