PAT-A1070 Mooncake 贪心

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region's culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (≤1000), the number of different kinds of mooncakes, and D (≤500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:

3 200
180 150 100
7.5 7.2 4.5

Sample Output:

9.45

没什么好讲的,结果体排序

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
struct node{
	double mount;
	double cost;
	double price;
};
bool cmp(const node n1,const node n2){
	return n1.price>n2.price;
}
int main(){
    vector<node> data;
	int num;
	double temp,demand;
	scanf("%d %lf",&num,&demand);
	int a=num;
	while(num--){
		node nodes;
		scanf("%lf",&temp);
		nodes.mount=temp;
		data.push_back(nodes);
	}
	for(int i=0;i<a;i++){
		scanf("%lf",&temp);
		data[i].cost=temp;
		data[i].price=data[i].cost/data[i].mount;
	}
	sort(data.begin(),data.end(),cmp);
	double sum=0.0;
	for(int j=0;j<a;j++){
		if(demand>data[j].mount){
			sum+=data[j].cost;
		}else{
			sum+=data[j].price*(demand);
			break;
		}
		demand-=data[j].mount;
	}
	printf("%.2lf",sum);
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
您的代码有一个错误,在定义结构体数组时,数组的大小必须是常量,不能是变量n,因为在编译时无法确定n的值。您可以使用动态内存分配来解决这个问题。请参考以下修改建议: ```c #include<stdio.h> #include<stdlib.h> struct mooncake{ double number; double price; double value; }; void swap(struct mooncake a[],int i,int j) { struct mooncake t = a[i]; a[i] = a[j]; a[j] = t; } int p(struct mooncake a[],int m,int n){ struct mooncake x = a[m]; int i = m; for(int j = m + 1; j <= n; j++){ if(a[j].value >= x.value){ i++; swap(a, i, j); } } swap(a, m, i); return i; } void q(struct mooncake a[],int m,int n){ int r; if(m < n){ r = p(a, m, n); q(a, m, r-1); q(a, r+1, n); } } int main() { int n; double d, value; while(scanf("%d%lf", &n, &d) != EOF){ struct mooncake* m = (struct mooncake*)malloc(n * sizeof(struct mooncake)); for(int i = 0; i < n; i++){ scanf("%lf", &m[i].number); } for(int i = 0; i < n; i++){ scanf("%lf", &m[i].price); m[i].value = m[i].price / m[i].number; } q(m, 0, n-1); value = 0; for(int i = n - 1; i >= 0; i--){ if(d >= m[i].number){ value += m[i].price; d -= m[i].number; } else { value += d * m[i].value; break; } } printf("%.2lf\n", value); free(m); } return 0; } ``` 这里使用了动态内存分配,通过malloc函数分配结构体数组的内存空间,在程序结束时使用free函数释放内存。同时,在快速排序算法中,将原来的比较大小方式改为比较价值大小,以实现降序排序。在计算总价值时,从大到小依次考虑每种月饼的数量,如果需求量大于该种月饼的数量,则全部购买该种月饼,继续考虑下一种月饼;否则,按需求量购买该种月饼,并计算对应的总价值即可。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值