PAT-A1065 A+B and C (64bit) 【大数相加】

Given three integers A, B and C in [−2e​63​​,2​e63​​], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

#include <iostream>
using namespace std;
#define maxint 2e63;
int main(){
	int n;
	long long  a,b,c,res;
	scanf("%d",&n);
	for(int i=1;i<=n;i++){
		scanf("%lld %lld %lld",&a,&b,&c);
		res=a+b;
		if(a>0 && b>0 &&res<0){
			printf("Case #%d: true\n",i);
		}
		else if(a<0&&b<0&&res>=0){
			printf("Case #%d: false\n",i);
		}
		else if(res>c){
			printf("Case #%d: true\n",i);
		}
		else{
			printf("Case #%d: false\n",i);
		}
	}
 return 0;
}

Tips:

  • int占四个字节,也就是4*8=32(bit),而题目中给出的数字范围是64(bit),需要使用long long 变量才可以,long int等于int
  • 两个正数相加结果如果溢出结果一定小于0,最大到-1但是不能等于0(即两个最大的正数相加),但是两个负数相加结果如果溢出,结果一定是大于等于0的(两个最小的负数相加即为0)
  • 关于判断是否溢出那里有个小疑惑,就是下面这两中种方式是不一样的,PAT后面两个测试跑不通。暂时记为只有赋值以后才能正确判断a+b是否溢出吧。诸君若知,请指点一二。
//1
a+b<0;
//2
res=a+b;
res<0

大数相加就是需要判断是否溢出,这就是这道题唯一的难点。从源头上思考一下,两个数相加为什么会溢出呢?因为你选用的类型表示范围有限,那么是不是我们选用一个比这个类型表示范围还要大的类型,即即使溢出也能正确表示结果是不是就没有判断溢出这个问题了,?Yes

long int会溢出,那么谁比这个类型大呢,long double

短小精悍,省时省心。

#include <iostream>
using namespace std;
#define maxint 2e63;
int main(){
	int n;
	long double  a,b,c;
	scanf("%d",&n);
	for(int i=1;i<=n;i++){
		scanf("%llf %llf %llf",&a,&b,&c);
		if(a+b>c){
			printf("Case #%d: true\n",i);
		}
		else{
			printf("Case #%d: false\n",i);
		}
	}
 return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值