PAT-A- 1037 Magic Coupon 【贪心算法】

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons N​C​​, followed by a line with N​C​​ coupon integers. Then the next line contains the number of products N​P​​, followed by a line with N​P​​ product values. Here 1≤N​C​​,N​P​​≤10​5​​, and it is guaranteed that all the numbers will not exceed 2​30​​.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

这道题还是蛮简单的,贪心算法。可以使用四个Vector来分别保存,coupon的正数部分,coupon的负数部分(名义上是负数部分,但是取反保存,为了可以和正数部分使用一个算法),product的正数部分,product的负数部分,遇到0舍弃

算法:

对两个vector进行从小到大排序,尾部对齐,相同位置相乘,直到某一个元素全部用完。比如样例可以这样描述:

代码没什么好讲的,就是上述图那个样子

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int getAdd(vector<int> cou,vector<int> pro){
	sort(cou.begin(),cou.end());
	sort(pro.begin(),pro.end());
	int indexc=cou.size();
	int indexp=pro.size();
	int sum=0;
	while(indexc&&indexp){
		sum+=cou[indexc-1]*pro[indexp-1];
		indexc--;
		indexp--;
	}
	return sum;
}
int main(){
	vector<int> couz;
	vector<int> proz;
	vector<int> couf;
	vector<int> prof;
	int n,m,temp;
	scanf("%d",&n);
	for(int i=0;i<n;i++){
        scanf("%d",&temp);
		if(temp>0) couz.push_back(temp);
		else if(temp==0) continue;
		else couf.push_back(-temp);
	}
	scanf("%d",&m);
	for(int j=0;j<m;j++){
        scanf("%d",&temp);
		if(temp>0) proz.push_back(temp);
		else if(temp==0) continue;
		else prof.push_back(-temp);
	}
	int sum=getAdd(couz,proz);
	sum+=getAdd(couf,prof);
	printf("%d",sum);
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值