PAT-A-1057 Stack 【桶排序】

Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian -- return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​5​​). Then N lines follow, each contains a command in one of the following 3 formats:

Push key
Pop
PeekMedian

where key is a positive integer no more than 10​5​​.

Output Specification:

For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print Invalid instead.

Sample Input:

17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop

Sample Output:

Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid

暴力算法,Stack保存数据,vector维持数据顺序,只过了两个案例。

#include <iostream>
#include <algorithm>
#include <stack>
#include <string.h>
#include <vector>
using namespace std;
int main(){
	int n;
	string flag;
	scanf("%d",&n);
	stack<int> data;
	char s[20];
	vector<int> da;
	int temp;
	for(int l=0;l<n;l++){
		scanf("%s",s);
		if(strlen(s)==3){
			if(data.empty()) printf("Invalid\n");
			else{
				int top=data.top();
				printf("%d\n",top);
				data.pop();
				int index=lower_bound(da.begin(),da.end(),top)-da.begin();
				da.erase(da.begin()+index,da.begin()+index+1);
			}
		}
		else if(strlen(s)==4){
			scanf("%d",&temp);
			data.push(temp);
			da.push_back(temp);
			sort(da.begin(),da.end());
		}
		else{
			if(data.empty()){
				if(data.empty()) printf("Invalid\n");
				continue;
			}
			int size=da.size(),mid;
			if(size%2){
				 mid=da[size/2];
			}else{
			     mid=da[size/2]>da[(size/2)-1]?da[(size/2)-1]:da[size/2];
			}
			printf("%d\n",mid);
			
		}

	}
	
	return 0;
}

 


stack一定不能丢,解决超时的问题一定是要从vector上入手

不使用vector维护数据列表,是用一个大数据维护.使用桶排序的思想来技术

#include <iostream>
#include <algorithm>
#include <stack>
#include <string.h>
#define max 100010
#define v 320
using namespace std;
stack<int> data;
int table[max];
int bucket[v];
void Push(int n){
	data.push(n);
	table[n]++;
	bucket[n/v]++;
}
int Pop(){
	int n=data.top();
	table[n]--;
	bucket[n/v]--;
	data.pop();
	return n;
}


int PeekMedian(){
	int index=(data.size()+1)/2;
	int i=0,j=0;
	while(i+bucket[j]<index){
		i+=bucket[j++];
	}
	int k=j*v;
	while(i+table[k]<index){
		i+=table[k++];
	}
	return k;
}
int main(){
	fill(table,table+max,0);
	fill(bucket,bucket+v,0);
	int N;
	char flag[20];
	scanf("%d",&N);
	for(int l=0;l<N;l++){
		scanf("%s",flag);
		if(strlen(flag)==3){
			if(data.size()==0) printf("Invalid\n");
			else printf("%d\n",Pop());
		}
		else if(strlen(flag)==4){
			int d;
			scanf("%d",&d);
			Push(d);
		}
		else{
			if(!data.size()) printf("Invalid\n");
			else printf("%d\n",PeekMedian());
		}
	}
return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值