POJ1013算法解析

POJ1008
Counterfeit Dollar
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 47335 Accepted: 14956

Description
Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins.
Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively.
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings.

Input
The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A–L. Information on a weighing will be given by two strings of letters and then one of the words up'',down”, or “even”. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.

Output
For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.

Sample Input

1
ABCD EFGH even
ABCI EFJK up
ABIJ EFGH even

Sample Output

K is the counterfeit coin and it is light.

要求是:先输入检测次数,每次带三个案例,从中比较出哪一枚是假币,并且判断这枚假币是轻的还是重的。

算法:在每个个例中进行检索,计数器初始化为0,当轻了计数器-1,当重了计数器+1,用计数值的绝对值来表示被怀疑程度,被怀疑程度最高的即为假币,此时重新检测他的计数值,当计数值大于0时,它比较重。当计数值小于0时,那么它比一般的正常货币轻。

AC代码(C语言)

#include<stdio.h> 
#include<math.h>  


int main()  
{  
    int cases; 
    int c,k,i,j; 
    scanf("%d",&cases);  
    for(c=1;c<=cases;c++)  
    {  
        char left[3][6],right[3][6],status[3][6];  

        int time['L'+1]={0};  
        int zero['L'+1]={0};    

        for(k=0;k<3;k++)  
            scanf("%s %s %s",left[k],right[k],status[k]);      

        for(i=0;i<3;i++)  
        {  
            switch(status[i][0]) 
            {  
                case 'u':      
                    {  
                        for(j=0;left[i][j];j++)  
                        {  
                            time[ left[i][j] ]++;    
                            time[ right[i][j] ]--;    
                        }  
                        break;  
                    }  

                case 'd':     //down,天枰左轻右重  
                    {  
                        for(j=0;left[i][j];j++)  
                        {  
                            time[ left[i][j] ]--;  //左轻  
                            time[ right[i][j] ]++;  //右重  
                        }  
                        break;  
                    } 

                case 'e':     //down,天枰平衡  
                    {  
                        for(j=0;left[i][j];j++)  
                        {  
                            zero[ left[i][j] ]=1;   //绝对真币  
                            zero[ right[i][j] ]=1;   //绝对真币  
                        }  
                        break;  
                    }  
            }  
        }  

        int max=-1;  //查找被怀疑程度最高的硬币(假币)  
        char alpha;  
        for(j='A';j<='L';j++)  
        {  
            if(zero[j])  //绝对真币  
                continue;  

            if(max<=abs(time[j]))  
            {  
                max=abs(time[j]);  
                alpha=j;  
            }  
        }  

        printf("%c is the counterfeit coin and it is ",alpha);  
        if(time[alpha]>0)  
            printf("light.\n"); 
        else  
            printf("heavy.\n");  
    }  
    return 0;  
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值