POJ 1915 BFS-Knight Moves

Description
Background
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him?
The Problem
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov.
For people not familiar with chess, the possible knight moves are shown in Figure 1.
这里写图片描述

Input
The input begins with the number n of scenarios on a single line by itself.
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, …, l-1}*{0, …, l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.

Output
For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.

Sample Input

3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1

Sample Output

5
28
0

*题意:*


国际象棋中的骑士,可以走如上面走的八个方向,即马走日,求骑士从一个点出发到另一个点最小的步数。


*题解:*


本题是一个较为简单的深度优先搜索问题,从起点开始向八个方向进行搜索,用队列保存这些点的坐标,当第一次搜索到目标点的时候就可以停止,可以知道此时目标点是最小的点,可以用一个数组记录每一个点是否被访问过,同时保存到达每一个点的步数。


#include <iostream>
#include <queue>
#include <string.h>
#define MAXN 300+5
using namespace std;

const int dx[] = {-2,-2,-1,-1,1,1,2,2};
const int dy[] = {1,-1,2,-2,2,-2,1,-1};

int vis[MAXN][MAXN];
queue<int> q;
int l;
int x0,y0;
int x1,y1;

void bfs()
{
    while(!q.empty()) q.pop();
    q.push(x0*l+y0);
    while(!q.empty())
    {
        int u = q.front();
        q.pop();
        int cx = u/l;
        int cy = u%l;
        if(cx == x1 && cy == y1)
        {
            cout << vis[cx][cy] << endl;
            return;
        }
        for(int k = 0; k < 8; k++)
        {
            int nx = cx + dx[k];
            int ny = cy + dy[k];
            if(nx >= 0 && nx < l && ny >= 0 && ny < l && vis[nx][ny] == 0)
            {
                vis[nx][ny] = vis[cx][cy] + 1;
                q.push(nx*l+ny);
            }
        }
    }
}

int main()
{
    int t;
    cin >> t;
    while(t--)
    {
        cin >> l;
        cin >> x0 >> y0;
        cin >> x1 >> y1;
        if(x0 == x1 && y0 == y1)
        {
            cout << 0 << endl;
            continue;
        }
        memset(vis, 0, sizeof(vis));
        bfs();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
POJ1915是一道经典的搜索题目,也被称为“Knight Moves”。下面我将为您提供解题思路和解题步骤: 1. 题目描述 在8x8的国际象棋棋盘上,棋子“马”从初始位置出发,允许走日字形的移动。给定目标位置,求出从初始位置到目标位置最少需要几步。 2. 解题思路 这道题目可以采用广度优先搜索(BFS)算法解决。将初始位置加入队列中,然后依次处理队列中的每个位置,根据“马”的走法,生成下一步可以到达的位置,如果这个位置没有被访问过,则将其加入队列中,并记录到达这个位置的步数。 3. 解题步骤 具体的解题步骤如下: (1)将初始位置加入队列中,并记录步数为0。 (2)依次处理队列中的每个位置,生成下一步可以到达的位置。 (3)如果下一步可以到达的位置没有被访问过,则将其加入队列中,并记录到达这个位置的步数为当前位置的步数+1。 (4)重复步骤(2)和(3),直到队列为空。 (5)如果目标位置被访问过,则返回到达目标位置的步数,否则返回-1。 4. 注意事项 在实现BFS算法的过程中,需要注意以下几点: (1)需要记录每个位置是否被访问过,以避免重复访问。 (2)需要注意边界条件,防止数组越界。 (3)需要注意判断目标位置是否合法,即是否在棋盘范围内。 5. 总结 本题是一道经典的搜索题目,采用BFS算法可以求解出从初始位置到目标位置最少需要几步。在解题过程中,需要注意边界条件和目标位置是否合法等问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值