POJ-1611 并查集-The Suspects

Description
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output
For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

题意:


病毒肆虐,现在有N个学生,编号是0到N-1,分为许多学生团体,一个学生可能在多个学生团体,且如果一个学生被怀疑感染病毒,则整个学生团体怀疑感染病毒,目前0号学生被怀疑感染病毒,问被怀疑感染病毒的有多少人。


题解:


本题是很简单的一个并查集问题。
如果不了解什么是并查集,可以到下面这个链接里面去看,我觉得讲得很好,第一次了解并查集就是看这个看懂的。
http://blog.csdn.net/qzc295919009/article/details/23306781
本题需要做的是对每个学生不断的进行合并操作,合并完之后再输出包含0号学生的团体的人数就好了。
完整AC代码如下。


#include <iostream>
#include <stdio.h>
#define MAXN 30010
using namespace std;

int fa[MAXN];
int sz[MAXN];

void init(int n)
{
    for(int i = 0; i < n; i++)
    {
        fa[i] = i;
        sz[i] =  1;
    }
}

int find(int x)
{
    return fa[x]==x?x:fa[x]=find(fa[x]);
}

void merge(int u, int v)
{
    int fu = find(u), fv = find(v);
    if(fu != fv)
    {
        fa[fv] = fu;
        sz[fu] += sz[fv];
        sz[fv] = 0;
    }
}

int main()
{
    int n,m,k,t;
    while(cin >> n >> m)
    {
        if(n == 0 && m == 0)
            break;
        init(n);
        for(int i = 0; i < m; i++)
        {
            scanf("%d", &k);
            int tmp = 0;
            for(int j = 0; j < k; j++)
            {
                scanf("%d", &t);
                if(j == 0)
                    tmp = t;
                else
                    merge(tmp,t);
            }
        }
        cout << sz[find(0)] << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值