Bull Math(高精度)

Description

Bulls are so much better at math than the cows. They can multiply huge integers together and get perfectly precise answers ... or so they say. Farmer John wonders if their answers are correct. Help him check the bulls' answers. Read in two positive integers (no more than 40 digits each) and compute their product. Output it as a normal number (with no extra leading zeros). 

FJ asks that you do this yourself; don't use a special library function for the multiplication.

Input

* Lines 1..2: Each line contains a single decimal number.

Output

* Line 1: The exact product of the two input lines

Sample Input

11111111111111
1111111111

Sample Output

12345679011110987654321

解题思路

代码借鉴的别人的,有待改善,可以不用指针,这题是两个大数的乘法。



AC代码

#include<iostream>
#include <stdlib.h>
#include<stdio.h>
#include<cstring>
using namespace std;
#define MAX 45
char mul1[MAX],mul2[MAX];
char ans[2 * MAX];

void mult(char* a, char* b, char* c)
{
    int i, j, ca, cb, *s;
    ca = strlen(a);
    cb = strlen(b);
    s=(int*)malloc(sizeof(int)*(ca+cb));                   //给s分配长度为ca+cb的内存块
    for(i = 0; i < ca + cb; i++)
        s[i] = 0;
    for(i=0; i<ca; i++)
        for(j = 0; j < cb; j++)
            s[i + j + 1] += (a[i] - '0') * (b[j] - '0');
    for(i = ca + cb - 1; i >= 0; i--)
        if(s[i] >= 10)
        {
            s[i-1] += s[i]/10;
            s[i] %= 10;
        }

    i=0;
    while(s[i] == 0)
        i++;
    for (j = 0; i < ca + cb; i++, j++)
        c[j] = s[i] + '0';
    c[j] = '\0';
    free(s);
}
int main()
{
     scanf("%s", mul1);
     scanf("%s", mul2);
     mult(mul1, mul2, ans);
     printf("%s\n", ans);
     return 0;
}








  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值