Exponentiation(高精度)

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 

This problem requires that you write a program to compute the exact value of R  n where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

Hint

If you don't know how to determine wheather encounted the end of input: 
s is a string and  n is an integer 
C++
while(cin>>s>>n)

{

...

}

c
while(scanf("%s%d",s,&n)==2) //to  see if the scanf read in as many items as you want 
/*while(scanf(%s%d",s,&n)!=EOF) //this also work    */

{

...

}

解题思路

大家看AC代码就行了,再次参考了userluoxuan的,故在此放上他的链接(http://blog.csdn.net/userluoxuan/article/details/38317623

未AC代码,样例能过,但如果次方数为1时,有bug,而且题意是必定有小数点的,看来我又理解错了,-_-!~~还是前面这篇思路更好些,

sscanf 字符串=>长整形的函数!!!!!!!



AC代码

#include <stdio.h>
#include <string.h>
const int maxn = 205;
int main()
{
    int n, ans[maxn], num, xiao[maxn], zhen[maxn];
    char R[maxn], str[10];
    while(scanf("%s", R) != EOF)
    {
        int pos = 0, k_1 = 0, k_2 = 0, k_3 = 0;
        memset(ans, 0, sizeof(ans));                       //全部初始化,我总是忘了
        memset(xiao, 0, sizeof(xiao));
        memset(zhen, 0, sizeof(zhen));
        scanf("%d", &n);
        for(int i = 0; i < 6; i++)
        {
            if(R[i] != '.')
                str[k_1++] = R[i];
            if(R[i] == '.')
                pos = i;                                //pos记录小数点的位置
        }
        str[k_1] = 0;
        sscanf(str,"%d", &num);                          //字符串转换成长整形
        for(int i = 0; i < 5; i++)
            ans[i] = str[5 - i - 1] - '0';
        for(int i = 0; i < n - 1; i++)
        {
            int d = 0;
            for(int j = 0; j < maxn; j++)
            {
                ans[j] = num * ans[j] + d;
                d = ans[j] / 10;
                ans[j] %= 10;
            }
        }
        bool isBegin = false;
        for(int i = 0; i < n * (5 - pos); i++)
        {
            if(isBegin)
                xiao[++k_2] = ans[i];

            else if(ans[i])
            {
                xiao[0] = ans[i];
                isBegin = true;
            }
        }
        isBegin = false;
        for(int i = maxn - 1; i >= n * (5 - pos); i--)           //注意整数和小数存储的顺序
        {
            if(isBegin)
            {
                zhen[++k_3] = ans[i];
            }
            else if(ans[i])
            {
                zhen[0] = ans[i];
                isBegin = true;
            }
        }
        if(zhen[0])
        {
            for(int i = 0; i <= k_3; i++)
            printf("%d",zhen[i]);
        }
        if(xiao[k_2] == 0 && k_2 == 0)
        {
            printf("\n");
            continue;
        }
        printf(".");
        for(int i = k_2; i >= 0; i--)
            printf("%d",xiao[i]);
        printf("\n");
    }
    return 0;
}

未AC代码

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 200;
int main()
{
    char str[10];
    int a[maxn], b[maxn], c[maxn], n, L, L_zhen, L_xiao, L_ans, L_a, L_b, L_c, h, i, j;

    while(scanf("%s%d", str, &n) != EOF)
    {
        L = strlen(str);
        L_xiao = 0;
        for(i = L - 1, j = 0; i >= 0; i--)
        {
            if(str[i] == '.')
                L_xiao = (5 - i) * n;
            else
            {
                b[j] = a[j] = str[i] - '0';
                j++;
            }
        }
        L_b = L_a = j;
        for(h = 2; h <= n; h++)
        {
            memset(c, 0, sizeof(c));
            for(i = 0; i < L_a; i++)
                for(j = 0; j < L_b; j++)
                    c[i + j] += a[i] * b[j];
            L_c = L_a + L_b - 1;
            for(i = 0; i < L_c; i++)
            {
                c[i + 1] += c[i] / 10;
                c[i] %= 10;
            }
            if(c[ L_c ])
                L_c += 1;
            for(i = 0; i < L_c; i++)
                b[i] = c[i];
            L_b = L_c;
        }

        L_zhen = L_c - L_xiao;
        L_ans = L_c;
        for(i = 0; i < L_c; i++)
        {
            if(c[i] == 0 && i + 1 <= L_xiao)
                L_ans--;
            if(c[i] != 0)
                break;
        }

        for(i = L_c - 1; i >= L_c - L_ans; i--)
        {
            if(i == L_c - L_zhen && L_zhen == 1 && c[i] == 0)
                continue;
            if(i == L_c - L_zhen - 1)
                printf(".%d", c[i]);
            else
                printf("%d", c[i]);
        }
        printf("\n");

    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值