Coder(线段树)

Description

  In mathematics and computer science, an algorithm describes a set of procedures or instructions that define a procedure. The term has become increasing popular since the advent of cheap and reliable computers. Many companies now employ a single coder to write an algorithm that will replace many other employees. An added benefit to the employer is that the coder will also become redundant once their work is done.  1
  You are now the signle coder, and have been assigned a new task writing code, since your boss would like to replace many other employees (and you when you become redundant once your task is complete). 
Your code should be able to complete a task to replace these employees who do nothing all day but eating: make the digest sum. 
  By saying “digest sum” we study some properties of data. For the sake of simplicity, our data is a set of integers. Your code should give response to following operations: 
  1. add x � add the element x to the set; 
  2. del x � remove the element x from the set; 
  3. sum � find the digest sum of the set. The digest sum should be understood by 

  where the set S is written as {a  1, a  2, ... , a  k} satisfying a  1 < a  2 < a  3 < ... < a  k
  Can you complete this task (and be then fired)? 
------------------------------------------------------------------------------ 
1 See http://uncyclopedia.wikia.com/wiki/Algorithm
 

Input

  There’re several test cases. 
  In each test case, the first line contains one integer N ( 1 <= N <= 10  5 ), the number of operations to process. 
  Then following is n lines, each one containing one of three operations: “add x” or “del x” or “sum”. 
  You may assume that 1 <= x <= 10  9
  Please see the sample for detailed format. 
  For any “add x” it is guaranteed that x is not currently in the set just before this operation. 
  For any “del x” it is guaranteed that x must currently be in the set just before this operation. 
  Please process until EOF (End Of File). 
 

Output

  For each operation “sum” please print one line containing exactly one integer denoting the digest sum of the current set. Print 0 if the set is empty. 
 

Sample Input

    
    
9 add 1 add 2 add 3 add 4 add 5 sum add 6 del 3 sum 6 add 1 add 3 add 5 add 7 add 9 sum
 

Sample Output

    
    
3 4 5

Hint

C++ maybe run faster than G++ in this problem.

解题思路






AC代码

#include<iostream>
#include <cstdio>
#include<algorithm>
using namespace std;
#define MAXN 100010
#define lson rt << 1
#define rson rt << 1 | 1
typedef long long LL;

int dat[MAXN], tmp[MAXN];
char cmd[MAXN][5];

struct Node
{
    int lef, rig;
    LL sum[5];
    int cnt;
}T[MAXN << 2];

void PushUp(int rt)
{
    for(int i = 0; i < 5; i++)
        T[rt].sum[i] = T[lson].sum[i] + T[rson].sum[ ((i - T[lson].cnt)%5 + 5) % 5 ];
}

void Build(int rt, int l, int r)
{
    T[rt].lef = l;
    T[rt].rig = r;
    T[rt].cnt = 0;
    for(int i = 0; i < 5; i++)
        T[rt].sum[i] = 0;
    if(l == r)
        return ;
    int mid = (l + r) >> 1;
    Build(lson, l , mid);
    Build(rson, mid + 1, r);
}

void Update(int rt, int pos, int val, int op)
{
    T[rt].cnt += op;
    if(T[rt].lef == T[rt].rig)
    {
        T[rt].sum[0] += val;
        return ;
    }
    else
    {
        if(pos <= T[lson].rig)
            Update(lson, pos, val, op);
        else
            Update(rson, pos, val, op);
        PushUp(rt);
    }
}

int main()
{
    int n;
    while(scanf("%d", &n) == 1)
    {
        int num = 0;
        for(int i = 0; i < n; i++)
        {
            scanf("%s", cmd[i]);
            if(cmd[i][0] != 's')
            {
                scanf("%d", &dat[i]);
                tmp[num++] = dat[i];
            }
        }
        sort(tmp, tmp + num);
        num = unique(tmp, tmp + num) - tmp;

        Build(1, 1, num);
        for(int i = 0; i < n; i++)
        {
            int pos = lower_bound(tmp, tmp + num, dat[i]) - tmp;
            if(cmd[i][0] == 'a')
                Update(1, pos, dat[i], 1);
            else if(cmd[i][0] == 'd')
                Update(1, pos, -dat[i], -1);
            else
                printf("%I64d\n", T[1].sum[2]);
        }
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
【项目资源】:包含前端、后端、移动开发、操作系统、人工智能、物联网、信息化管理、数据库、硬件开发、大数据、课程资源、音视频、网站开发等各种技术项目的源码。包括STM32、ESP8266、PHP、QT、Linux、iOS、C++、Java、MATLAB、python、web、C#、EDA、proteus、RTOS等项目的源码。 【项目质量】:所有源码都经过严格测试,可以直接运行。功能在确认正常工作后才上传。 【适用人群】:适用于希望学习不同技术领域的小白或进阶学习者。可作为毕设项目、课程设计、大作业、工程实训或初期项目立项。 【附加价值】:项目具有较高的学习借鉴价值,也可直接拿来修改复刻。对于有一定基础或热衷于研究的人来说,可以在这些基础代码上进行修改和扩展,实现其他功能。 【沟通交流】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。鼓励下载和使用,并欢迎大家互相学习,共同进步。【项目资源】:包含前端、后端、移动开发、操作系统、人工智能、物联网、信息化管理、数据库、硬件开发、大数据、课程资源、音视频、网站开发等各种技术项目的源码。包括STM32、ESP8266、PHP、QT、Linux、iOS、C++、Java、MATLAB、python、web、C#、EDA、proteus、RTOS等项目的源码。 【项目质量】:所有源码都经过严格测试,可以直接运行。功能在确认正常工作后才上传。 【适用人群】:适用于希望学习不同技术领域的小白或进阶学习者。可作为毕设项目、课程设计、大作业、工程实训或初期项目立项。 【附加价值】:项目具有较高的学习借鉴价值,也可直接拿来修改复刻。对于有一定基础或热衷于研究的人来说,可以在这些基础代码上进行修改和扩展,实现其他功能。 【沟通交流】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。鼓励下载和使用,并欢迎大家互相学习,共同进步。【项目资源】:包含前端、后端、移动开发、操作系统、人工智能、物联网、信息化管理、数据库、硬件开发、大数据、课程资源、音视频、网站开发等各种技术项目的源码。包括STM32、ESP8266、PHP、QT、Linux、iOS、C++、Java、MATLAB、python、web、C#、EDA、proteus、RTOS等项目的源码。 【项目质量】:所有源码都经过严格测试,可以直接运行。功能在确认正常工作后才上传。 【适用人群】:适用于希望学习不同技术领域的小白或进阶学习者。可作为毕设项目、课程设计、大作业、工程实训或初期项目立项。 【附加价值】:项目具有较高的学习借鉴价值,也可直接拿来修改复刻。对于有一定基础或热衷于研究的人来说,可以在这些基础代码上进行修改和扩展,实现其他功能。 【沟通交流】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。鼓励下载和使用,并欢迎大家互相学习,共同进步。【项目资源】:包含前端、后端、移动开发、操作系统、人工智能、物联网、信息化管理、数据库、硬件开发、大数据、课程资源、音视频、网站开发等各种技术项目的源码。包括STM32、ESP8266、PHP、QT、Linux、iOS、C++、Java、MATLAB、python、web、C#、EDA、proteus、RTOS等项目的源码。 【项目质量】:所有源码都经过严格测试,可以直接运行。功能在确认正常工作后才上传。 【适用人群】:适用于希望学习不同技术领域的小白或进阶学习者。可作为毕设项目、课程设计、大作业、工程实训或初期项目立项。 【附加价值】:项目具有较高的学习借鉴价值,也可直接拿来修改复刻。对于有一定基础或热衷于研究的人来说,可以在这些基础代码上进行修改和扩展,实现其他功能。 【沟通交流】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。鼓励下载和使用,并欢迎大家互相学习,共同进步。【项目资源】:包含前端、后端、移动开发、操作系统、人工智能、物联网、信息化管理、数据库、硬件开发、大数据、课程资源、音视频、网站开发等各种技术项目的源码。包括STM32、ESP8266、PHP、QT、Linux、iOS、C++、Java、MATLAB、python、web、C#、EDA、proteus、RTOS等项目的源码。 【项目质量】:所有源码都经过严格测试,可以直接运行。功能在确认正常工作后才上传。 【适用人群】:适用于希望学习不同技术领域的小白或进阶学习者。可作为毕设项目、课程设计、大作业、工程实训或初期项目立项。 【附加价值】:项目具有较高的学习借鉴价值,也可直接拿来修改复刻。对于有一定基础或热衷于研究的人来说,可以在这些基础代码上进行修改和扩展,实现其他功能。 【沟通交流】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。鼓励下载和使用,并欢迎大家互相学习,共同进步。【项目资源
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值