Coder(线段树+多棵线段树)

Coder

Time Limit : 20000/10000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 12   Accepted Submission(s) : 7
Problem Description
  In mathematics and computer science, an algorithm describes a set of procedures or instructions that define a procedure. The term has become increasing popular since the advent of cheap and reliable computers. Many companies now employ a single coder to write an algorithm that will replace many other employees. An added benefit to the employer is that the coder will also become redundant once their work is done.  1
  You are now the signle coder, and have been assigned a new task writing code, since your boss would like to replace many other employees (and you when you become redundant once your task is complete).
Your code should be able to complete a task to replace these employees who do nothing all day but eating: make the digest sum.
  By saying “digest sum” we study some properties of data. For the sake of simplicity, our data is a set of integers. Your code should give response to following operations:
  1. add x – add the element x to the set;
  2. del x – remove the element x from the set;
  3. sum – find the digest sum of the set. The digest sum should be understood by

  where the set S is written as {a 1, a 2, ... , a k} satisfying a 1 < a 2 < a 3 < ... < a k 
  Can you complete this task (and be then fired)?
------------------------------------------------------------------------------
1 See http://uncyclopedia.wikia.com/wiki/Algorithm
 

Input
  There’re several test cases.   In each test case, the first line contains one integer N ( 1 <= N <= 10[sup]5[/sup] ), the number of operations to process.   Then following is n lines, each one containing one of three operations: “add x” or “del x” or “sum”.   You may assume that 1 <= x <= 10[sup]9[/sup].   Please see the sample for detailed format.   For any “add x” it is guaranteed that x is not currently in the set just before this operation.   For any “del x” it is guaranteed that x must currently be in the set just before this operation.   Please process until EOF (End Of File).
 

Output
  For each operation “sum” please print one line containing exactly one integer denoting the digest sum of the current set. Print 0 if the set is empty.
 

Sample Input
   
   
9 add 1 add 2 add 3 add 4 add 5 sum add 6 del 3 sum 6 add 1 add 3 add 5 add 7 add 9 sum
 

Sample Output
   
   
3 4 5 [hint]C++ maybe run faster than G++ in this problem.[/hint]
 

Source
2012 ACM/ICPC Asia Regional Chengdu Online
 

Statistic |  Submit |  Back

题意:
维护一个有序数列{An},有三种操作:
1、添加一个元素。
2、删除一个元素。
3、求数列中下标%5 = 3的值的和。

由于有删除和添加操作,所以离线离散操作,节点中cnt存储区间中有几个数,sum存储偏移和

代码:

#include<iostream>  
#include<cstdio>  
#include<cstring>  
#include<algorithm>  
using namespace std;  
typedef long long ll;
#define maxn 100002
#define lson l , m , rt << 1    
#define rson m + 1 , r , rt << 1 | 1 
#define L(rt) (rt<<1)
#define R(rt) (rt<<1|1)
   
ll sum[maxn<<2][6]; //存储偏移和
 
int cnt[maxn << 2];   //存储区间中有几个数

char op[maxn][20];  

int a[maxn];  
  
int X[maxn];  
  
void PushUp(int i) 
{  
    cnt[i] = cnt[L(i)] + cnt[R(i)];  
      
    int t=cnt[L(i)];  
    for(int j = 0; j < 5; ++j)  
    {  
        sum[i][j] = sum[L(i)][j];  
    }  
    for(int k=0;k < 5; ++k)  
    {  
        sum[i][(k + t) % 5] += sum[R(i)][k];  
    }  
}  
 
void Build(int l, int r, int rt)    
{ 
    cnt[rt] = 0;
    for(int i = 0; i < 5; ++i)   
    sum[rt][i] = 0;
    if( l == r ) 
    return;  
    int m= (l+r)>>1;      
    Build(lson);    
    Build(rson);     
}   
  
void Updata(int p, int op, int l, int r, int rt)    
{     
    if(l==r)    
    {    
        cnt[rt]=op;   
        sum[rt][1]=op*X[l-1];   
        return;    
    }    
    int m = ( l + r ) >> 1;    
    if(p <= m)    
        Updata(p, op, lson);    
    else    
        Updata(p, op, rson);    
    
    PushUp(rt);    
}   
  
int main()  
{  
    int n;  
    while(scanf("%d", &n) != EOF)  
    {  
        int nn = 0;  
        for(int i = 0; i < n; ++i)  
        {  
            scanf("%s", &op[i]);  
              
            if(op[i][0] != 's')  
            {  
                scanf("%d", &a[i]);  
                if(op[i][0] == 'a')  
                {  
                    X[nn++] = a[i];  
                }  
            }  
        }  
          
        sort(X,X+nn);//unique前必须sor
        nn = unique(X, X + nn) - X;//去重并得到总数
        Build(1, nn, 1);
        for(int i = 0; i < n; ++i)  
        {  
            int pos = upper_bound(X, X+nn, a[i]) - X;
            if(op[i][0] == 'a')  
            {  
                Updata(pos, 1, 1, nn, 1);  
            }  
            else if(op[i][0] == 'd') 
            {  
                Updata(pos, 0, 1, nn, 1);  
            }  
            else printf("%lld\n",sum[1][3]);  
        }  
    }  
    return 0;  
}  


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值