Coder(暴力)

Description

  In mathematics and computer science, an algorithm describes a set of procedures or instructions that define a procedure. The term has become increasing popular since the advent of cheap and reliable computers. Many companies now employ a single coder to write an algorithm that will replace many other employees. An added benefit to the employer is that the coder will also become redundant once their work is done.  1
  You are now the signle coder, and have been assigned a new task writing code, since your boss would like to replace many other employees (and you when you become redundant once your task is complete). 
Your code should be able to complete a task to replace these employees who do nothing all day but eating: make the digest sum. 
  By saying “digest sum” we study some properties of data. For the sake of simplicity, our data is a set of integers. Your code should give response to following operations: 
  1. add x � add the element x to the set; 
  2. del x � remove the element x from the set; 
  3. sum � find the digest sum of the set. The digest sum should be understood by 

  where the set S is written as {a  1, a  2, ... , a  k} satisfying a  1 < a  2 < a  3 < ... < a  k
  Can you complete this task (and be then fired)? 
------------------------------------------------------------------------------ 
1 See http://uncyclopedia.wikia.com/wiki/Algorithm
 

Input

  There’re several test cases. 
  In each test case, the first line contains one integer N ( 1 <= N <= 10  5 ), the number of operations to process. 
  Then following is n lines, each one containing one of three operations: “add x” or “del x” or “sum”. 
  You may assume that 1 <= x <= 10  9
  Please see the sample for detailed format. 
  For any “add x” it is guaranteed that x is not currently in the set just before this operation. 
  For any “del x” it is guaranteed that x must currently be in the set just before this operation. 
  Please process until EOF (End Of File). 
 

Output

  For each operation “sum” please print one line containing exactly one integer denoting the digest sum of the current set. Print 0 if the set is empty. 
 

Sample Input

    
    
9 add 1 add 2 add 3 add 4 add 5 sum add 6 del 3 sum 6 add 1 add 3 add 5 add 7 add 9 sum
 

Sample Output

    
    
3 4 5

解题思路:

本来该题是应该用线段树来做的,可实在是无思路,就暴力来解了,没想到竟然AC了,但程序也跑了8000多毫秒。等日后有了思路,再用线段树做一遍。

注意:插入元素的同时就得进行排序。

AC代码:

#include <iostream>
#include <cstdio>
using namespace std;
const int maxn = 100005;
int a[maxn];
int main()
{
    int n, j, b, len;
    __int64 sum;
    char ord[10];
    while(scanf("%d", &n) != EOF)
    {
        len = 0;
        for(int i = 0; i < n; i++)
        {
            scanf("%s", ord);
            if(ord[0] != 's')
            {
                scanf("%d", &b);
                if(ord[0] == 'a')
                {
                    int i;
                    for(i = len + 1; i >= 2; i--)
                    {
                        if(b < a[i - 1])
                            a[i] = a[i - 1];
                        else
                            break;
                    }
                    a[i] = b;
                    len++;
                }
                else
                {
                    bool isFind = false;
                    for(int i = 1; i < len; i++)
                    {
                        if(a[i] == b)
                        {
                            a[i] = a[i + 1];
                            isFind = true;
                        }
                        if(isFind)
                            a[i] = a[i + 1];
                    }
                    len--;
                }
            }
            else
            {
                sum = 0;
                for(int i = 3; i <= len; i += 5)
                    sum += a[i];
                printf("%I64d\n", sum);
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值