#1020. The Largest Generation【树的遍历 + BFS】

原题链接

Problem Description:

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N N N ( < 100 <100 <100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N N N), and M M M ( < N <N <N) which is the number of family members who have children. Then M M M lines follow, each contains the information of a family member in the following format:

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

Sample Output:

9 4

Problem Analysis:

BFS 遍历整颗树,记录每一个节点到根节点的距离 dist 作为层数,然后将同层数的所有点数累加起来,最后遍历所有节点,输出结点数最大的层数及其所包含结点数即可。

Code

#include <iostream>
#include <algorithm>
#include <cstring>

using namespace std;

const int N = 110;

int n, m;
int h[N], e[N], ne[N], idx;
int q[N], dist[N];
int cnt[N]; // 每个层数的点数

void add(int a, int b)
{
	e[idx] = b, ne[idx] = h[a], h[a] = idx ++ ;
}

void bfs(int root)
{
	memset(dist, 0x3f, sizeof dist);
	int hh = 0, tt = -1;
	q[ ++ tt] = root;
	dist[root] = 1;
	while (hh <= tt)
	{
		auto t = q[hh ++ ];
		for (int i = h[t]; ~i; i = ne[i])
		{
			int j = e[i];
			if (dist[j] > dist[t] + 1)
			{
				dist[j] = dist[t] + 1;
				q[ ++ tt] = j;
			}
		}
	}
}

int main()
{
	ios::sync_with_stdio(false), cin.tie(0);
	cin >> n >> m;
	memset(h, -1, sizeof h);
	for (int i = 0; i < m; i ++ )
	{	
		int root, siz;
		cin >> root >> siz;
		for (int j = 0; j < siz; j ++ )
		{
			int child;
			cin >> child;
			add(root, child);
		}
	}

	bfs(1);

	int maxd = -1, id = -1;
	for (int i = 1; i <= n; i ++ )
	{
		int d = dist[i];
		cnt[d] ++ ;
		if (cnt[d] > maxd) maxd = cnt[d], id = d;
	}
	cout << maxd << ' ' << id;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值