#1146. Topological Order【拓扑排序】

原题链接

Problem Description:

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.
在这里插入图片描述

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N N N ( ≤ 1 , 000 \leq 1,000 1,000), the number of vertices in the graph, and M M M ( ≤ 10 , 000 \leq 10,000 10,000), the number of directed edges. Then M M M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N N N. After the graph, there is another positive integer K K K ( ≤ 100 \leq 100 100). Then K K K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to “NOT a topological order”. The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
6
5 2 3 6 4 1
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

0 4 5

Problem Analysis:

拓扑排序详细步骤说明见:AcWing 848. 有向图的拓扑序列

由于本题是判断给定的一个序列是否是给定有向图的一个拓扑序列,因此我们只需要效仿输出拓扑序列的方式,枚举序列中的每一个点,如果其入度不为 0 0 0,证明这不是一个拓扑序列,因为在构造过程中,我们总是优先让入度为 0 0 0 的点排在序列前面;反之其入度为 0 0 0,那么就让这个节点能过够到达的点入度全部减 1 1 1

Code

#include <iostream>
#include <algorithm>
#include <cstring>

using namespace std;

const int N = 1e4 + 10;

int n, m;
int h[N], e[N], ne[N], idx;
int d[N], q[N], tmp[N];
int ans[N], cnt;

void add(int a, int b)
{
    e[idx] = b, ne[idx] = h[a], h[a] = idx ++ ;
}   

bool is_topsort()
{
    for (int i = 0; i < n; i ++ ) 
    {
        int t = q[i];
        if (tmp[t])
            return false;
        for (int j = h[t]; ~j; j = ne[j]) -- tmp[e[j]];
    }
    return true;
}

int main()
{
    cin >> n >> m;
    memset(h, -1, sizeof h);
    while (m -- )
    {
        int a, b;
        cin >> a >> b;
        add(a, b);
        ++ d[b];
    }

    int T;
    cin >> T;

    for (int t = 0; t < T; t ++ )
    {
        memcpy(tmp, d, sizeof d);
        for (int i = 0; i < n; i ++ ) scanf("%d", &q[i]);
        if (!is_topsort()) ans[cnt ++ ] = t;
    }

    for (int i = 0; i < cnt; i ++ ) // 处理输出格式
    {
        printf("%d", ans[i]);
        if (i != cnt - 1) printf(" ");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值