【POJ 2387】 Til the Cows Come Home 最短路 Dijkstra

Til the Cows Come Home

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 80865 Accepted: 26668

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

题意:给你两个数字T,N,有N个点,T条边,接下来T行,每行三个数字,u,v, w,代表从u点到v点的距离为w,问你从1点走到N点的最短距离为多少。

题解:一道最短路的水题。

​
#include<cstdio>
using namespace std;
const int maxn=1000+7;
const int INF=1<<29;
int cost[maxn][maxn];
int low[maxn];
int vis[maxn];
int t,n,u,v,w;
int Dijkstra()
{
    int min,pos;
    for(int i=0;i<n;i++)  vis[i]=0;
    for(int i=0;i<n;i++){
        if(i==0) low[i]=0;  //源点距离初始化为0
        else low[i]=INF;    //其余点距离初始化为无穷大
    }
    for(int i=0;i<n;i++){
        min=INF,pos=-1;
        for(int j=0;j<n;j++){
            if(vis[j]==0&&low[j]<min){
                min=low[j];
                pos=j;
            }
        }
        vis[pos]=1;
        for(int j=0;j<n;j++){      //松弛
            if(!vis[j]&&low[pos]+cost[pos][j]<low[j]){
                low[j]=low[pos]+cost[pos][j];
            }
        }
    }
    return low[n-1];
}
int main()
{
    while(scanf("%d %d",&t,&n)==2){
        for(int i=0;i<n;i++){
            for(int j=0;j<n;j++){
                cost[i][j]=INF;
            }
        }
        for(int i=0;i<t;i++){
            scanf("%d %d %d",&u,&v,&w);
            if(w<cost[u-1][v-1]){        //重边判断
                cost[u-1][v-1]=cost[v-1][u-1]=w;
            }
        }
        int res=Dijkstra();
        printf("%d\n",res);
    }
    return 0;
}

​

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值