【 POJ 1265】 Area Pick定理

Area

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 7815 Accepted: 3279

Description

Being well known for its highly innovative products, Merck would definitely be a good target for industrial espionage. To protect its brand-new research and development facility the company has installed the latest system of surveillance robots patrolling the area. These robots move along the walls of the facility and report suspicious observations to the central security office. The only flaw in the system a competitor抯 agent could find is the fact that the robots radio their movements unencrypted. Not being able to find out more, the agent wants to use that information to calculate the exact size of the area occupied by the new facility. It is public knowledge that all the corners of the building are situated on a rectangular grid and that only straight walls are used. Figure 1 shows the course of a robot around an example area. 


 
Figure 1: Example area. 


You are hired to write a program that calculates the area occupied by the new facility from the movements of a robot along its walls. You can assume that this area is a polygon with corners on a rectangular grid. However, your boss insists that you use a formula he is so proud to have found somewhere. The formula relates the number I of grid points inside the polygon, the number E of grid points on the edges, and the total area A of the polygon. Unfortunately, you have lost the sheet on which he had written down that simple formula for you, so your first task is to find the formula yourself. 

Input

The first line contains the number of scenarios. 
For each scenario, you are given the number m, 3 <= m < 100, of movements of the robot in the first line. The following m lines contain pairs 揹x dy�of integers, separated by a single blank, satisfying .-100 <= dx, dy <= 100 and (dx, dy) != (0, 0). Such a pair means that the robot moves on to a grid point dx units to the right and dy units upwards on the grid (with respect to the current position). You can assume that the curve along which the robot moves is closed and that it does not intersect or even touch itself except for the start and end points. The robot moves anti-clockwise around the building, so the area to be calculated lies to the left of the curve. It is known in advance that the whole polygon would fit into a square on the grid with a side length of 100 units. 

Output

The output for every scenario begins with a line containing 揝cenario #i:� where i is the number of the scenario starting at 1. Then print a single line containing I, E, and A, the area A rounded to one digit after the decimal point. Separate the three numbers by two single blanks. Terminate the output for the scenario with a blank line.

Sample Input

2
4
1 0
0 1
-1 0
0 -1
7
5 0
1 3
-2 2
-1 0
0 -3
-3 1
0 -3

Sample Output

Scenario #1:
0 4 1.0

Scenario #2:
12 16 19.0

题意 :有一个机器人在网格中走路,从原点(0, 0)  出发,每次在上一次横坐标的基础上增加 dx,纵坐标在上一次的基础上增加dy,机器人走的路会围成一个多边形,求多边形边上内部点数,边上点数,面积。

题解:直接运用Pick(皮克)定理。面积 = 边上点数 / 2 + 内部点数 - 1。边上点数可以用 gcd 求出,面积可以用三角形面积和求出,利用叉积。POJ double 输出只能用 %f ,%lf 会一直 wa。

#include<cstdio>
using namespace std;
const int maxn = 1000+7;
typedef struct {
  int x;
  int y;
}point;
point p[maxn];
int t, n, kase, inside, onedge, area;
int ABS(int x)
{
  return x < 0 ? -x : x;
}
int gcd(int a, int b)  
{
  if(b == 0) return a;
  else return gcd(b, a%b);
}
int grid_onedge(int n, point* p)  //多边形边上点的个数
{
  int ret = 0;
  for(int i = 0; i < n; i++) ret += gcd(ABS(p[i].x-p[(i+1)%n].x),ABS(p[i].y-p[(i+1)%n].y));
  return ret ;
}
int grid_inside(int n, point* p)   // 多边形内点的个数
{
  area = 0;   // 面积
  for(int i = 0; i < n; i++) area += p[(i+1)%n].y*(p[i].x-p[(i+2)%n].x);
  if(area < 0) area = -area;
  return (area-onedge)/2 + 1;
}
int main()
{
  kase = 0;
  scanf("%d",&t);
  while(t--){
    scanf("%d",&n);
    int dx, dy;
    p[0].x = 0, p[0].y = 0;
    for(int i = 0; i < n; i++){
      scanf("%d %d",&dx, &dy);
      p[(i+1)%n].x = p[i].x + dx;
      p[(i+1)%n].y = p[i].y + dy;
    }
    onedge = grid_onedge(n, p);
    inside = grid_inside(n, p);
    printf("Scenario #%d:\n",++kase);
    printf("%d %d %.1f\n\n",inside,onedge,area/2.0);  //POJ double 要用f% 不能用lf% 不然一直 WA
  }
  return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值