PAT (Advanced Level)1008解

因为最近在刷题库,想想就把本人可以想到的解法写到博客里,作为整理归纳。未必是最优解,还请各位高手多多包涵,能够指点指点。

题目要求
1008 Elevator (20 分)
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

解题思路
求出两层楼之间的差判断正负再乘上对应的时间加上停留时间即可。代码简洁利落,题目也简单易懂。
注意事项
无。。。太简单了
代码部分

#include<cstdio>
#include<cstring> 
using namespace std;
main(){
  int N,sum=0 ,k=1,A[101],temp;
  memset(A,0xff,sizeof(A));
  scanf("%d",&N);
  for(int i =0;i<N;i++)
    scanf("%d",&A[i]);
  sum+=A[0]*6+5;
  while(A[k]!=-1){
    temp=A[k]-A[k-1];
    if(temp>0)//上升
      sum+=temp*6+5;
    else
      sum+=-temp*4+5;
      k++;
  }
  printf("%d",sum);
}

运行结果
在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值