Function Run Fun--CSU-ACM2017暑期训练3-递推与递归



We all love recursion! Don't we? 


Consider a three-parameter recursive function w(a, b, c): 


if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns: 



if a > 20 or b > 20 or c > 20, then w(a, b, c) returns: 
w(20, 20, 20) 


if a < b and b < c, then w(a, b, c) returns: 
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c) 


otherwise it returns: 
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1) 


This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion. 
Input
The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.
Output
Print the value for w(a,b,c) for each triple.
Sample Input
1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1
Sample Output
w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1










当a,b,c过大时,我们就会发现其实这个过程中某些情况被递归了很多次,浪费了不少的时间。但是只要我们中途当第一次递归到这种情况时能把这个值存储下来,之后的递归再遇到这种情况时就直接用这个值,无需再把这种情况递归下去。这样我们就能节省许多时间。这就是记忆化搜索的基本思想吧。



#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int store[24][24][24];

int recur(int a,int b,int c)
{
    if(a<=0||b<=0||c<=0)return 1;
    if(a>20||b>20||c>20)return recur(20,20,20);
    if(store[a][b][c])return store[a][b][c];
    if(a<b&&b<c) store[a][b][c]=recur(a,b,c-1)+recur(a,b-1,c-1)-recur(a,b-1,c);
    else store[a][b][c]=recur(a-1,b,c)+recur(a-1,b-1,c)+recur(a-1,b,c-1)-recur(a-1,b-1,c-1);
    return store[a][b][c];
}

int main()
{
    int a,b,c;
    memset(store,0,sizeof(store));
    while(cin>>a>>b>>c)
    {
        if(a==-1&&b==-1&&c==-1)break;
        printf("w(%d, %d, %d) = %d\n",a,b,c,recur(a,b,c));
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值