PTA 1101 Quick Sort

 

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

  • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
  • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
  • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
  • and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then the next line contains N distinct positive integers no larger than 10​9​​. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

5
1 3 2 4 5

Sample Output:

3
1 4 5

 题目大意:

给定一个数字N,下面有N个数字,找出所有的(该数字左边的数字皆小于他&&该数字右边的数字皆大于他)的数,输出他的数量,并输出这些数字

解析: 

解决的办法挺简单的,快速排序一下看看哪些数字的位置没有变,并且从0到该数字的这些数字中的最大值为这个数字即可。但是有一个坑!!在测试点2那个地方,会出现cnt = 0的情况,并且这时候还需要继续输出一行空行,哇我在这个点上卡了好久!!!!

[○・`Д´・ ○]生气

贴代码

#include <iostream>
#include <cstring>
#include <cstdio>
#include<algorithm>
#include <cmath>
#include<queue>
#include<map>
#include<stack>
#include<sstream>
using namespace std;
const int maxn = 1e5+7;
int a[maxn],b[maxn],c[maxn];
int cmp(int i, int j)
{
    return a[i] < a[j];
}

int main()
{
    int n;
    cin >> n;
    int cnt = 0;

    for(int i = 0; i < n; i ++)
    {
        scanf("%d",&a[i]);
        b[i] = i;
    }
    sort(b,b+n,cmp);
    int maxx = b[0];
    //if(b[0] == 0)c[0] = a[0];
    for(int i = 0; i < n; i ++)
    {
        maxx = max(maxx,b[i]);
        if(b[i] == i&&maxx == i)
        {
            c[cnt++] = a[i];
        }
    }
    cout << cnt << endl;
    if(cnt!=0)
    {
        cout << c[0];
    for(int i = 1; i < cnt; i ++)cout << " " << c[i];
    }
    cout <<endl;
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值