原题链接 http://poj.org/problem?id=1012
Joseph
Description
The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.
Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.
Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.
Input
The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.
Output
The output file will consist of separate lines containing m corresponding to k in the input file.
Sample Input
3 4 0
Sample Output
5 30
Source Code
/*
题目数据量太小,直接模拟Joseph暴力打表也能过。这里介绍一下递推法测试。
先引入Joseph递推公式,设有n个人(0,...,n-1),数m,则第i轮出局的人为f(i)=(f(i-1)+m-1)%(n-i+1),f(0)=0;
依次我们可以来做测试,只要前k轮中只要有一次f(i)<k则此m不符合题意。
接下来我们考察一下只剩下k+1个人时候情况,那么依题意则这一轮出局的人要么在上一轮出局人的左边,要么就在右边,
设上一轮出局的人为x,则必有m%(k+1)==0或1(还不明白就看下面两个序列表示的k+2人的情况(G表示好人,共有k个,B表示坏人,
X表示上一轮出局的人)GG....GGBX,GG...GGXB)。所以测试数为t(k+1)或t(k+1)+1,t>=1。
*/
#include<iostream>
using namespace std;
bool checkIsOk(int k, int m) {
int i, executed;
int n = 2 * k;
executed = 0;
for (i = 0; i < k; i ++) {
executed = (executed + m - 1) % (n - i);
if (executed < k) {
return false;
}
}
return true;
}
int main() {
int result[20];
int i, k, position;
int m;
for (i = 0; i < 14; i++) {
m = i + 1;
while(1) {
if (checkIsOk(i, m)){
result[i] = m;
break;
}
if (checkIsOk(i, m + 1)) {
result[i] = m + 1;
break;
}
m += (i + 1);
}
}
while (scanf("%d", &k) != EOF) {
if (k == 0){
break;
}
printf("%d\n", result[k]);
}
}