A Simple Problem with Integers

区间更新,区间求和

http://poj.org/problem?id=3468

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 87351 Accepted: 27114
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <map>
#include <set>
#include <stack>
#include <cmath>
#include <string>
#include <iostream>
#include <string>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define LL long long
const int SIZE=1e5+10;
using namespace std;
struct sge{
    LL sum;
    LL lazy;
}a[SIZE<<2];
void pushup(int rt){
    a[rt].sum=a[rt<<1].sum+a[rt<<1|1].sum;
}
void pushdown(int l,int r,int rt){
    if(a[rt].lazy){
        int m=(r-l+1);
        a[rt<<1].sum+=(m-m/2)*a[rt].lazy;
        a[rt<<1|1].sum+=(m/2)*a[rt].lazy;
        a[rt<<1].lazy+=a[rt].lazy;
        a[rt<<1|1].lazy+=a[rt].lazy;
        a[rt].lazy=0;
    }
}
void build(int l,int r,int rt){
    a[rt].lazy=0;
    if(l==r){
        scanf("%lld",&a[rt].sum);
        return;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    pushup(rt);
}
void update(int L,int R,int c,int l,int r,int rt){
    if(L<=l&&r<=R){
        a[rt].sum+=(r-l+1)*c;
        a[rt].lazy+=c;
        return;
    }
    pushdown(l,r,rt);
    int m=(l+r)>>1;
    if(L<=m)update(L,R,c,lson);
    if(R>m)update(L,R,c,rson);
    pushup(rt);
}
LL query(int L,int R,int l,int r,int rt){
    if(L<=l&&r<=R){
        return a[rt].sum;
    }
    pushdown(l,r,rt);
    int m=(l+r)>>1;
    LL sum=0;
    if(L<=m)sum+=query(L,R,lson);
    if(R>m)sum+=query(L,R,rson);
    return sum;
}
int main()
{
    int n,q,x,y,c;
    char s[10];
    while(scanf("%d%d",&n,&q)!=EOF){
        build(1,n,1);
        for(int i=0;i<q;i++){
            scanf("%s",s);
            if(s[0]=='Q'){
                scanf("%d%d",&x,&y);
                printf("%lld\n",query(x,y,1,n,1));
            }
            else {
                scanf("%d%d%d",&x,&y,&c);
                update(x,y,c,1,n,1);
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值