Assign the task(dfs+线段树_

http://acm.hdu.edu.cn/showproblem.php?pid=3974

Assign the task

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1737    Accepted Submission(s): 793


Problem Description
There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordinates are your subordinates as well. If you are nobody's boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole company.So it means the N employees form a tree.

The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever a employee received a task,he/she will stop the current task(if he/she has) and start the new one.

Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee.
 

Input
The first line contains a single positive integer T( T <= 10 ), indicates the number of test cases.

For each test case:

The first line contains an integer N (N ≤ 50,000) , which is the number of the employees.

The following N - 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1<=u,v<=N).

The next line contains an integer M (M ≤ 50,000).

The following M lines each contain a message which is either

"C x" which means an inquiry for the current task of employee x

or

"T x y"which means the company assign task y to employee x.

(1<=x<=N,0<=y<=10^9)
 

Output
For each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line.
 

Sample Input
      
      
1 5 4 3 3 2 1 3 5 2 5 C 3 T 2 1 C 3 T 3 2 C 3
 

Sample Output
      
      
Case #1: -1 1 2
 

#include <cstdio>
#include <cstring>
#include <algorithm>
#define lson l,m,rt<<1 
#define rson m+1,r,rt<<1|1
const int SIZE=5e4+10;
using namespace std;
struct Edge{
	int v,next;
}edge[SIZE];
struct sge{
	int test;
	int lazy;
}a[SIZE<<2];
int head[SIZE],tot,Start[SIZE],End[SIZE];
bool vis[SIZE];
void init(){
	memset(head,-1,sizeof(head));
	memset(vis,false,sizeof(vis));
	tot=0;
}
void addedge(int u,int v){
	edge[tot].v=v;
	edge[tot].next=head[u];
	head[u]=tot++;
}
void dfs(int rt){//样例,更新2是更新区间1-5
	Start[rt]=++tot;
	for(int i=head[rt];~i;i=edge[i].next){
		dfs(edge[i].v);
	}
	End[rt]=tot;
}
void build(int l,int r,int rt){
	a[rt].test=-1;
	a[rt].lazy=0;
	if(l==r)return ;
	int m=(l+r)>>1;
	build(lson);
	build(rson);
}
void pushdown(int rt){
	if(a[rt].lazy){
		a[rt<<1].test=a[rt<<1].lazy=a[rt].lazy;
		a[rt<<1|1].test=a[rt<<1|1].lazy=a[rt].lazy;
		a[rt].lazy=0;
	}
}
int query(int pos,int l,int r,int rt){
	if(a[rt].test!=-2)return a[rt].test;//-2表示没有统一工作
	pushdown(rt);
	int m=(l+r)>>1;
	if(pos<=m)return query(pos,lson);
	return query(pos,rson);
}
void pushup(int rt){
	if(a[rt<<1].test==a[rt<<1|1].test)a[rt].test=a[rt<<1].test;
	else a[rt].test=-2;
}
void update(int L,int R,int c,int l,int r,int rt){
	if(L<=l&&r<=R){
		a[rt].test=c;
		a[rt].lazy=c;
		return ;
	}
	pushdown(rt);
	int m=(l+r)>>1;
	if(L<=m)update(L,R,c,lson);
	if(R>m)update(L,R,c,rson);
	pushup(rt);
}
int main(){
	int T,n,u,v,m,x,y;
	char s[3];
	scanf("%d",&T);
	for(int cas=1;cas<=T;cas++){
		printf("Case #%d:\n",cas);
		init();
		scanf("%d",&n);
		for(int i=1;i<n;i++){
			scanf("%d%d",&u,&v);
			addedge(v,u);
			vis[u]=true;//u存在boss
		}
		tot=0;
		for(int i=1;i<=n;i++)
			if(!vis[i]){
				dfs(i);
				break;
			}
		build(1,n,1);//区间1-n建树,根节点的数组下表默认是1
		scanf("%d",&m);
		for(int i=0;i<m;i++){
			scanf("%s",s);
			if(s[0]=='C'){
				scanf("%d",&x);//查询节点Start[x] test
				printf("%d\n",query(Start[x],1,n,1));
			}
			else {
				scanf("%d%d",&x,&y);
				update(Start[x],End[x],y,1,n,1);
			}
		}
	}
	return 0;
}

很好的水题

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
if(local_point_id+keep_point+chang_lane_point<x_orignal.size()) { local_x.assign(x_orignal.begin()+local_point_id,x_orignal.begin()+local_point_id+keep_point+1); local_y.assign(y_orignal.begin()+local_point_id,y_orignal.begin()+local_point_id+keep_point+1); local_yaw.assign(yaw_orignal.begin()+local_point_id,yaw_orignal.begin()+local_point_id+keep_point); for (unsigned int i = 0; i < int(chang_lane_point/2); i++) { double local_xx=(i+1)*abs(x_average); double local_yy=(local_axis_point[1]/abs(local_axis_point[1]))*(i+1)*abs(x_average) * tan(change_rate_angle*(i+1)); local_x.push_back(local_xx*cos(yaw_orignal[local_point_id+keep_point])-local_yy*sin(yaw_orignal[local_point_id+keep_point])+x_orignal[local_point_id+keep_point]); local_y.push_back(local_xx*sin(yaw_orignal[local_point_id+keep_point])+local_yy*cos(yaw_orignal[local_point_id+keep_point])+y_orignal[local_point_id+keep_point]); local_yaw.push_back(change_rate_angle*(i+1)); } local_x.push_back(local_axis_point[0]/2*cos(yaw_orignal[local_point_id+keep_point])-local_axis_point[1]/2*sin(yaw_orignal[local_point_id+keep_point])+x_orignal[local_point_id+keep_point] ); local_y.push_back(local_axis_point[0]/2*sin(yaw_orignal[local_point_id+keep_point])+local_axis_point[1]/2*cos(yaw_orignal[local_point_id+keep_point])+y_orignal[local_point_id+keep_point] ); local_yaw.push_back(change_rate_angle*12); for (unsigned int i = 0; i < int(chang_lane_point/2); i++) { double local_xx_2=local_axis_point[0]-(int(chang_lane_point/2)-i)*abs(x_average); double local_yy_2=local_axis_point[1]-(local_axis_point[1]/abs(local_axis_point[1]))*(int(chang_lane_point/2)-i)*abs(x_average) * tan((change_rate_angle*(int(chang_lane_point/2)-i))); local_x.push_back(local_xx_2*cos(yaw_orignal[local_point_id+keep_point] )-local_yy_2*sin(yaw_orignal[local_point_id+keep_point] )+x_orignal[local_point_id+keep_point]); local_y.push_back(local_xx_2*sin(yaw_orignal[local_point_id+keep_point] )+local_yy_2*cos(yaw_orignal[local_point_id+keep_point] )+y_orignal[local_point_id+keep_point]); local_yaw.push_back(change_rate_angle*(int(chang_lane_point/2)-i)); } if(keep_point+chang_lane_point<local_path_size) { local_x.insert(local_x.end(),x_target.begin()+local_point_id+keep_point+chang_lane_point,x_target.begin()+(local_path_size+local_point_id-1)); local_y.insert(local_y.end(),y_target.begin()+local_point_id+keep_point+chang_lane_point,y_target.begin()+(local_path_size+local_point_id-1)); local_yaw.insert(local_yaw.end(),yaw_orignal.begin()+local_point_id+keep_point+chang_lane_point,yaw_orignal.begin()+(local_path_size+local_point_id-1)); } else { cout<<"keep_point + chang_lane_point 大于"<<local_path_size<<endl; }
最新发布
07-25

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值