线段树-------J - Assign the task

There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordinates are your subordinates as well. If you are nobody’s boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole company.So it means the N employees form a tree.

The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever a employee received a task,he/she will stop the current task(if he/she has) and start the new one.

Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee.
Input
The first line contains a single positive integer T( T <= 10 ), indicates the number of test cases.

For each test case:

The first line contains an integer N (N ≤ 50,000) , which is the number of the employees.

The following N - 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1<=u,v<=N).

The next line contains an integer M (M ≤ 50,000).

The following M lines each contain a message which is either

“C x” which means an inquiry for the current task of employee x

or

"T x y"which means the company assign task y to employee x.

(1<=x<=N,0<=y<=10^9)
Output
For each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line.
Sample Input
1
5
4 3
3 2
1 3
5 2
5
C 3
T 2 1
C 3
T 3 2
C 3
Sample Output
Case #1:
-1
1
2

这个题有点难想,不知道怎么建树。。。
这道题只需要遍历一下树,把每个树上的节点重新编号,用sta,en数组存储每个节点的字节,从哪儿开始到哪儿结束(是连续的),每次T修改节点时,每个节点对应一个区间,直接用线段树的区间更新即可。。。。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<map>
#include<cmath>
using namespace std;
typedef long long LL;
const int inf = 0x3f3f3f3f;
#define pb push_back
#define mp make_pair
#define fi first
#define se second
const int N = 50005;

int sta[N],en[N];
int index;
vector<int>ve[N];
bool vis[N];

void dfs(int k)
{
    sta[k] = ++index;
    int len = ve[k].size();
    for(int i = 0;i < len;++i){
        dfs(ve[k][i]);
    }
    en[k] = index;
}

typedef struct Node{
    int task,lazy;
}Node;
Node tree[N << 2];

void pushdown(int root)
{
    if(tree[root].lazy){
        tree[root * 2 + 1].lazy = tree[root * 2 + 2].lazy = tree[root].lazy;
        tree[root * 2 + 1].task = tree[root * 2 + 2].task = tree[root].task;
        tree[root].lazy = 0;
    }
}

void update(int root,int l,int r,int pl,int pr,int task)
{
    if(r < pl || l > pr){
        return ;
    }
    if(l >= pl && r <= pr){
        tree[root].lazy = 1;
        tree[root].task = task;
        return ;
    }
    pushdown(root);
    int mid = (l + r) / 2;
    if(pl <= mid){
        update(root * 2 + 1,l,mid,pl,pr,task);
    }
    if(pr > mid){
        update(root * 2 + 2,mid + 1,r,pl,pr,task);
    }
}

int query(int root,int l,int r,int index)
{
    if(l == r && l == index){
        return tree[root].task;
    }
    pushdown(root);
    int mid = (l + r) / 2;
    if(index <= mid){
        return query(root * 2 + 1,l,mid,index);
    }else{
        return query(root * 2 + 2,mid + 1,r,index);
    }
}

int main()
{
    int cnt = 0;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        cnt++;
        scanf("%d",&n);
        for(int i = 1;i <= n;++i){
            ve[i].clear();
        }
        memset(vis,false,sizeof(vis));
        for(int i = 0;i < n - 1;++i){
            int u,v;
            scanf("%d %d",&u,&v);
            vis[u] = true;
            ve[v].pb(u);
        }
        index = 0;
        for(int i = 1;i <= n;++i){
            if(!vis[i]){
                dfs(i);break;
            }
        }
        for(int i = 1;i < (N << 2);++i){
            tree[i].task = -1;
            tree[i].lazy = 0;
        }
        int m;
        printf("Case #%d:\n",cnt);
        scanf("%d",&m);
        while(m--)
        {
            char ch;
            scanf(" %c",&ch);
            //cout << ch << endl;
            if(ch == 'C'){
                int x;
                scanf("%d",&x);
                //cout << x << endl;
                printf("%d\n",query(1,1,n,sta[x]));
            }else{
                int x,y;
                scanf("%d %d",&x,&y);
                //cout << x << " " << y << endl;
                update(1,1,n,sta[x],en[x],y);
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值