HDU1113 Word Amalgamation

 

Description

In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four words. Your task is to write a program that can unscramble words.

Input

The input contains four parts: 1) a dictionary, which consists of at least one and at most 100 words, one per line; 2) a line containing XXXXXX, which signals the end of the dictionary; 3) one or more scrambled 'words' that you must unscramble, each on a line by itself; and 4) another line containing XXXXXX, which signals the end of the file. All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X's.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique.

Output

For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a line by itself. If the list is empty (because no dictionary words can be formed), output the line "NOT A VALID WORD" instead. In either case, output a line containing six asterisks to signal the end of the list.

Sample Input

tarp
given
score
refund
only
trap
work
earn
course
pepper
part
XXXXXX
resco
nfudre
aptr
sett
oresuc
XXXXXX

Sample Output

score
******
refund
******
part
tarp
trap
******
NOT A VALID WORD
******
course
******

Attention:对若干个字符串进行字典排序,应用结构体数组储存字符串(二维数组会报错),以用函数 sort 进行排序。

Code:

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <ctime>
#include <ctype.h>

using namespace std;

char wd[100][15],wd_sort[100][15];

struct w
{
    char res[15];
}wd_rs[100];

bool cmp(struct w a,struct w b)
{
    return strcmp(a.res,b.res)<0;
}
int main()
{
    char wt[15];
    int len=0;
    while(scanf("%s",wt)&&strcmp(wt,"XXXXXX"))
    {
        strcpy(wd[len],wt);
        strcpy(wd_sort[len],wd[len]);
        len++;
    }

    int k=len;
    while(k--)
    {
        sort(wd_sort[k],wd_sort[k]+strlen(wd_sort[k]));
    }

    char w[15];
    while(scanf("%s",w)&&strcmp(w,"XXXXXX"))
    {
        sort(w,w+strlen(w));

        int flag=0,z=0;
        k=len;
        for(int i=0;i<=k;i++)
        {
            if(strcmp(wd_sort[i],w)==0)
            {
                strcpy(wd_rs[z++].res,wd[i]);
                flag=1;
            }
        }
        if(!flag)
            printf("NOT A VALID WORD\n");
        else
        {
            sort(wd_rs,wd_rs+z,cmp);
            for(int i=0;i<z;i++)
                printf("%s\n",wd_rs[i].res);
        }
        printf("******\n");
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值