UVA 1592 Database(map)

Peter studies the theory of relational databases. Table in the relational database consists of values that are arranged in rows and columns.

There are different normal forms that database may adhere to. Normal forms are designed to minimize the redundancy of data in the database. For example, a database table for a library might have a row for each book and columns for book name, book author, and author's email.

If the same author wrote several books, then this representation is clearly redundant. To formally define this kind of redundancy Peter has introduced his own normal form. A table is in Peter's Normal Form (PNF) if and only if there is no pair of rows and a pair of columns such that the values in the corresponding columns are the same for both rows.

How to compete in ACM ICPCPeterpeter@neerc.ifmo.ru
How to win ACM ICPCMichaelmichael@neerc.ifmo.ru
Notes from ACM ICPC championMichaelmichael@neerc.ifmo.ru


The above table is clearly not in PNF, since values for 2rd and 3rd columns repeat in 2nd and 3rd rows. However, if we introduce unique author identifier and split this table into two tables -- one containing book name and author id, and the other containing book id, author name, and author email, then both resulting tables will be in PNF.

$\textstyle \parbox{.5\textwidth}{\begin{center}\begin{tabular}{\vert l\vert l......\hlineNotes from ACM ICPC champion & 2 \\\hline\end{tabular}\end{center}}$$\textstyle \parbox{.49\textwidth}{\begin{center}\begin{tabular}{\vert l\vert ......ine2 & Michael & michael@neerc.ifmo.ru \\\hline\end{tabular}\end{center}}$

Given a table your task is to figure out whether it is in PNF or not.

Input 

Input contains several datasets. The first line of each dataset contains two integer numbersn and m (1$ \le$n$ \le$10000, 1$ \le$m$ \le$10), the number of rows and columns in the table. The following n lines contain table rows. Each row hasm column values separated by commas. Column values consist of ASCII characters from space (ASCII code 32) to tilde (ASCII code 126) with the exception of comma (ASCII code 44). Values are not empty and have no leading and trailing spaces. Each row has at most 80 characters (including separating commas).

Output 

For each dataset, if the table is in PNF write to the output file a single word ``YES" (without quotes). If the table is not in PNF, then write three lines. On the first line write a single word ``NO" (without quotes). On the second line write two integer row numbers r1 andr2 (1$ \le$r1,r2$ \le$n,r1$ \ne$r2), on the third line write two integer column numbers c1 andc2 (1$ \le$c1,c2$ \le$m,c1$ \ne$c2), so that values in columnsc1 andc2 are the same in rowsr1 andr2.

Sample Input 


3 3
aj ji le*jh
juj la na_
aj ji le*jh
2 4
jfi jai ne ji
knja jei nda j
3 4
knja jei nda j
juj la na_ o9o
jj jei nda o


Sample Output 


YES

NO
YES
 
 
题意及题解源于紫书P128。
 
代码:
#include <iostream>
#include <algorithm>
#include <cstdlib>
#include <map>
#include <vector>


using namespace std;


int main()
{
    int n,m;
    while(cin>>n>>m)
    {
        string s[n][m];
        map<string,int> d_ma;

        int cnt=0;
        for(int i=0;i<n;i++)
        for(int j=0;j<m;j++)
        {
            cin>>s[i][j];
            if(!d_ma.count(s[i][j]))
            {
                d_ma[s[i][j]]=cnt;
                cnt++;
            }
        }

        int flag=0;
        map<int,int> d_int;

        for(int i=0;i<m-1;i++)
        {
            for(int j=i+1;j<m;j++)
            {
                for(int k=0;k<n;k++)
                {
                    if(i==0&&j==i+1&&k==0)
                        d_int[d_ma[s[k][i]]]=d_ma[s[k][j]];
                    else
                    {
                        if(d_int[d_ma[s[k][i]]]==d_ma[s[k][j]])//判断map 中是否已经存在该二元组
                        {
                            cout<<"YES"<<endl;
                            flag=1;
                            break;
                        }
                        else
                            d_int[d_ma[s[k][i]]]=d_ma[s[k][j]];//添加新二元组
                    }
                }
                if(flag)
                    break;
            }
            if(flag)
                break;
        }

        if(!flag)
            cout<<"NO"<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值