PAT Advanced 1151 【LCA in a Binary Tree 】

题目描述

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.
Given any two nodes in a binary tree, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found…

Sample Input:

6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

解题思路

由二叉搜索树bst的先序遍历可以判断ancestor:如果有结点的大小位于要查找的两个结点的大小之间,则这个结点就是我们要查找的ancestor。由上我们只要对已知的中序(中序遍历进行编号正好满足bst)二叉树依次编号,再利用先序遍历找ancestor即可。

Code

	#include<bits/stdc++.h>
	using namespace std;
	map<int, int> bst, res;
	vector<int> pre;
	
	int main() {
		freopen("in.txt", "r", stdin);
		int M, N, node, id = 1;
		cin >> M >> N;
		for(int i = 0; i<N; i++) {
			cin >> node;
			res[id] = node;
			bst[node] = id++;
		}
		for(int i = 0; i<N; i++) {
			cin >> node;
			pre.push_back(bst[node]);
		}
		int u, v;
		for(int i = 0; i<M; i++) {
			cin >> u >> v;
			bool isExistU = true, isExistV = true;
			if(!bst[u]) isExistU = false;
			if(!bst[v]) isExistV = false;
			if(isExistU && !isExistV) {
				cout << "ERROR: " << v << " is not found.\n";
			} else if(isExistV && !isExistU) {
				cout << "ERROR: " << u << " is not found.\n";
			} else if(!isExistU && !isExistV) {
				cout << "ERROR: " << u << " and " << v << " are not found.\n";
			} else {
				u = bst[u], v = bst[v];
				for(int j = 0; j<pre.size(); j++) {
					if((pre[j] > u && pre[j] < v) || (pre[j] > v && pre[j] < u)) {
						cout << "LCA of " << res[u] << " and " << res[v] << " is " << res[pre[j]] << ".\n";
						break;
					} else if(pre[j] == u) {
						cout << res[u] << " is an ancestor of " << res[v] << ".\n";
						break;
					} else if(pre[j] == v) {
						cout << res[v] << " is an ancestor of " << res[u] << ".\n";
						break;
					} 
				} 
			}
		}
		return 0;
	}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值