PAT Advanced—1151 LCA in a Binary Tree (30分)

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.
Given any two nodes in a binary tree, you are supposed to find their LCA.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.
Output Specification:
For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found…
Sample Input:
6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

Sample Output:
LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

题目大意:
  二叉树中U和V的LAC结点是最近公共祖先结点

思路:

  1. 主要是如何判断结点是否为最近公共祖先结点
  2. 如果a,b分别在根结点结点的左右,则说明这个根结点就是最近共同祖先结点
  3. 如果都在左边,在左子树中寻找
  4. 如果都在右边,则在右子树中寻找
  5. 主要是通过中序遍历和前序遍历如何构造二叉树
  6. 可以用map来存各个结点的位置,及map<键,位置>

代码:(C++)

#include<iostream>
#include<vector>
#include<map>

using namespace std;

map<int, int> pos;  //记录中序的值的位置,也可以用于判断是否检测结点是否在树中
vector<int> in, pre;  //保存中序和先序遍历

//inl中序遍历结点最左端,inr中序遍历结点最右端,preRoot先序遍历的根结点位置
void lca(int inl, int inr, int preRoot, int a, int b)
{
	if(inl > inr)  //左边界大于右边界说明没有子树了
		return;
	//pre中记录了先序结点的位置,先序结点位置,通过先序的根结点找到中序的根结点位置
	int inRoot = pos[pre[preRoot]], aIn = pos[a], bIn = pos[b];
	//都在左边,遍历左子树
	if(aIn < inRoot && bIn < inRoot)
		lca(inl, inRoot-1, preRoot+1, a, b);
	//分别在两边,当前根节点即为最近祖先结点
	else if((aIn < inRoot && bIn > inRoot) || (aIn > inRoot && bIn < inRoot))  //关键思路是这里的最终判断
		printf("LCA of %d and %d is %d.\n", a, b, in[inRoot]);
	//都在右子树,根结点的位置为当前根节点为中序根节点距离左端位置
	else if(aIn > inRoot && bIn > inRoot)
		lca(inRoot+1, inr, preRoot+1+(inRoot-inl), a, b);
	//a为b的父节点
	else if(aIn == inRoot)
		printf("%d is an ancestor of %d.\n", a, b);
	//b为a的父节点
	else if(bIn == inRoot)
		printf("%d is an ancestor of %d.\n", b, a);
}

int main()
{
	//m是多少对结点要被测试
	//n是树的结点个数
	//a和b分别是要测试的两个结点
	int m,n,a,b;
	scanf("%d %d", &m, &n);
	in.resize(n+1);
	pre.resize(n+1); //重新分配大小
	for(int i=1; i<=n; i++)
	{
		scanf("%d", &in[i]);
		pos[in[i]] = i;  //记录中序遍历的值
	}
	for(int i=1; i<=n; i++)
		scanf("%d", &pre[i]);
	for(int i=0; i<m; i++)  //输入需要测试的结点
	{
		scanf("%d %d", &a, &b);
		if(pos[a] == 0 && pos[b] == 0)  //两个结点都不存在
			printf("ERROR: %d and %d are not found.\n", a, b);
		else if(pos[a] == 0 || pos[b] == 0)  //一个结点不存在
			printf("ERROR: %d is not found.\n", pos[a] == 0 ? a : b);
		else
			lca(1, n, 1, a, b);  //开始使用查找最近共同祖先结点
	}
	
	return 0;
}

参考:
  https://blog.csdn.net/liuchuo/article/details/82560863

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值