【BFS】poj 1979 Red and Black

7 篇文章 0 订阅
Red and Black
Time Limit: 1000MS
Memory Limit: 30000K
Total Submissions: 36059
Accepted: 19536

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13


///AC代码
#include <iostream>
#include <set>
#include <map>
#include <stack>
#include <cmath>
#include <queue>
#include <cstdio>
#include <bitset>
#include <string>
#include <vector>
#include <iomanip>
#include <cstring>
#include <algorithm>
#include <functional>
#define PI acos(-1)
#define eps 1e-8
#define inf 0x3f3f3f3f
#define debug(x) cout<<"---"<<x<<"---"<<endl
typedef long long ll;
using namespace std;

char str[25][25];
bool vis[25][25];
int m, n;
int dix[4] = {1, -1, 0, 0};
int diy[4] = {0, 0, 1, -1};

struct node
{
    int x, y;
};
int cango(int x, int y)
{
    return x >= 0 && x < m && y >= 0 && y < n && vis[x][y] == false;
}
int bfs(int x, int y)
{
    queue<node> qu;
    node gg;
    gg.x = x;
    gg.y = y;
    qu.push(gg);
    memset(vis, false, sizeof(vis));
    vis[x][y] = true;
    int sum = 0;

    while (!qu.empty())
    {
        gg = qu.front();
        qu.pop();
        sum++;

        for (int i = 0; i < 4; i++)
        {
            int _x = gg.x + dix[i];
            int _y = gg.y + diy[i];
            if (cango(_x, _y) && str[_x][_y] == '.')
            {
                node hh;
                hh.x = _x;
                hh.y = _y;
                qu.push(hh);
                vis[_x][_y] = true;
            }
        }
    }
    return sum;
}


int main()
{
    while (cin >> n >> m && m + n)
    {
        int ans;
        for (int i = 0; i < m; i++)
        {
            cin >> str[i];
        }
        for (int i = 0; i < m; i++)
        {
            for (int j = 0; j < n; j++)
            {
                if (str[i][j] == '@')
                {
                    ans = bfs(i, j);
                    break;
                }
            }
        }
        cout << ans << endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值