HDUOJ-1702 ACboy needs your help again!


ACboy needs your help again!
Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6949    Accepted Submission(s): 3611


Problem Description
ACboy was kidnapped!!
he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.
As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").
and the following N lines, each line is "IN M" or "OUT", (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!
 

Input
The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.
 

Output
For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.
 

Sample Input

4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT

 

Sample Output

1
2
2
1
1
2
None
2

3

题意:有多组实例,根据FIFO或FILO来输出数字,若没有数字输出就输出None;

思路:根据栈和队列的特性可知FIFO为队列,FILO为栈;其实就是考察栈和队列的基本应用;

下面附上代码 :(自己写的,代码很长。。。QAQ)

#include<cstdio>
#include<algorithm>
#include<queue>
#include<stack>
#include<cstring>
using namespace std;
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int a,b,l;
		char o[10];
		char m[10];
		queue<int> q;
		stack<int> s;
		memset(o,0,sizeof(o));
		scanf("%d%s",&a,m);
		if(!strcmp(m,"FIFO"))
		{
			for(int i=0;i<a;i++)
			{
				scanf("%s",o);
				if(!strcmp(o,"IN"))
				{
					scanf("%d",&b);
					q.push(b); 
				}
				else
				{
					if(!q.empty())
					{
						l=q.front();
						q.pop();
						printf("%d\n",l);
					}
					else
						puts("None");
				}
			}
		}
		if(!strcmp(m,"FILO"))
		{
			for(int i=0;i<a;i++)
			{
				scanf("%s",o);
				if(!strcmp(o,"IN"))
				{
					scanf("%d",&b);
					s.push(b); 
				}
				else
				{
					if(!s.empty())
					{
						l=s.top();
						s.pop();
						printf("%d\n",l);
					}
					else
						puts("None");
				}
			}
		}
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值