HDU 2955 Robberies (01背包)

Robberies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 27311    Accepted Submission(s): 10065


Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

Sample Input
  
  
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
 

Sample Output
  
  
2 4 6
题意:一个小偷想要抢劫银行,给你小偷计划抢劫银行的钱数以及被抓的概率,要求在低于被抓的概率下得到的最大钱数;

思路:一开始很容易理解为将概率作为总的背包容量,但显然是没法遍历的,所以我们将钱数作为总容量,那么状态转移方程的定义就是为在钱数最大下的最大逃跑的概率,这样就很好理解了,我们首先将被抓概率转化为逃跑概率,抢一个银行,逃跑的概率就会减小(注意概率是相乘的),然后我们用01背包求出最大的逃跑概率,最后遍历一遍,一旦找出大于题目要求的逃跑概率,输出总钱数即可;

下面附上我的代码:

 

#include<bits/stdc++.h>
using namespace std;
double dp[10050],w[105];
int v[105];
double Max(double x,double y)
{
	if(x>y)
		return x;
	return y;
}
int main()
{
	int t,N;
	double P;
	cin>>t;
	while(t--)
	{
		scanf("%lf %d",&P,&N);
		int sum=0;
		for(int i=0;i<N;i++)
		{
			scanf("%d %lf",&v[i],&w[i]);
			sum+=v[i];
			w[i]=1-w[i];//逃跑概率 
		}
		memset(dp,0,sizeof(dp));
		dp[0]=1;
		for(int i=0;i<N;i++)
			for(int j=sum;j>=v[i];j--)
				dp[j]=Max(dp[j],dp[j-v[i]]*w[i]);//抢银行的概率是乘积 
		for(int j=sum;j>=0;j--)
		{
			if(dp[j]>=1-P)//抢劫的钱数大于逃跑的概率即可(钱数最大并且能成功逃脱 
			{
				printf("%d\n",j);
				break;
			}
		}
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值