HDU-3488(二分图最大权匹配+有向环最小权值覆盖)

题目:HDU - 3488 

In the kingdom of Henryy, there are N (2 <= N <= 200) cities, with M (M <= 30000) one-way roads connecting them. You are lucky enough to have a chance to have a tour in the kingdom. The route should be designed as: The route should contain one or more loops. (A loop is a route like: A->B->……->P->A.) 
Every city should be just in one route. 
A loop should have at least two cities. In one route, each city should be visited just once. (The only exception is that the first and the last city should be the same and this city is visited twice.) 
The total distance the N roads you have chosen should be minimized. 

Input

An integer T in the first line indicates the number of the test cases. 
In each test case, the first line contains two integers N and M, indicating the number of the cities and the one-way roads. Then M lines followed, each line has three integers U, V and W (0 < W <= 10000), indicating that there is a road from U to V, with the distance of W. 
It is guaranteed that at least one valid arrangement of the tour is existed. 
A blank line is followed after each test case.

Output

For each test case, output a line with exactly one integer, which is the minimum total distance.

Sample Input

1
6 9
1 2 5
2 3 5
3 1 10
3 4 12
4 1 8
4 6 11
5 4 7
5 6 9
6 5 4

Sample Output

42

题意:N个点,M条边的有向图,边有正权,求使每个点至少属于一个环的路径的最小权和(2 <= N <= 200,M <= 30000,0 < 每个边权W <= 10000)

分析:有向图的不相交环的覆盖问题,直接用KM求最大权匹配,但是这里需要求的最小权,所以只需要 将权值取相反数,但是不确定是否有重边,就加个判断。

 

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;

const int maxn = 347;
const int INF = 0x3f3f3f3f;
int nx,ny;
int g[maxn][maxn];
int linker[maxn],lx[maxn],ly[maxn];
int slack[maxn];
bool visx[maxn],visy[maxn];
int n,m;
bool dfs(int x)
{
    visx[x] = true;
    for(int y = 0;y < ny;y ++)
    {
        if(visy[y]) continue;
        int tmp = lx[x] + ly[y] - g[x][y];
        if(tmp == 0)
        {
            visy[y] = true;
            if(linker[y] == -1 || dfs(linker[y]))
            {
                linker[y] = x;
                return true;
            }
        }
        else if(slack[y] > tmp)
        {
            slack[y] = tmp;
        }
    }
    return false;
}

int KM()
{
    memset(linker,-1,sizeof(linker));
    memset(ly,0,sizeof(ly));
    for(int i = 0;i < nx;i ++)
    {
        lx[i] = -INF;
        for(int j = 0;j < ny;j ++)
        {
            if(g[i][j] > lx[i])
            {
                lx[i] = g[i][j];
            }
        }
    }
    for(int x = 0;x < nx;x ++)
    {
        for(int i = 0;i < ny;i ++)
        slack[i] = INF;
        while(true)
        {
            memset(visx,false,sizeof visx);
            memset(visy,false,sizeof(visy));
            if(dfs(x)) break;
            int d = INF;
            for(int i = 0;i < ny;i ++)
            {
                if(! visy[i] && d > slack[i])
                {
                    d = slack[i];
                }
            }
            for(int i = 0;i < nx;i ++)
            {
                if(visx[i])
                    lx[i] -= d;
            }
            for(int i = 0;i < ny;i ++)
            {
                if(visy[i])
                    ly[i] += d;
                else slack[i] -= d;
            }
        }
    }
    int  res = 0;
    for(int i = 0;i < ny;i ++)
    {
        if(linker[i] != -1)
        {
            res += g[linker[i]][i];
        }
    }
    return -res;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T --)
    {
        int u,v,w;
        scanf("%d%d",&n,&m);
        for(int i = 0;i < n;i ++)
        {
            for(int j = 0;j < n;j ++)
            {
                g[i][j] = -INF;
            }
        }
        while(m --)
        {
            scanf("%d%d%d",&u,&v,&w);
            u --;v --;
            g[u][v] = max(g[u][v],-w);
        }
        nx = ny = n;
        printf("%d\n",KM());
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值