ZOJ-3469(区间dp)

题目:ZOJ - 3469 

When we are focusing on solving problems, we usually prefer to stay in front of computers rather than go out for lunch. At this time, we may call for food delivery.

Suppose there are N people living in a straight street that is just lies on an X-coordinate axis. The ith person's coordinate is Xi meters. And in the street there is a take-out restaurant which has coordinates X meters. One day at lunchtime, each person takes an order from the restaurant at the same time. As a worker in the restaurant, you need to start from the restaurant, send food to the N people, and then come back to the restaurant. Your speed is V-1 meters per minute.

You know that the N people have different personal characters; therefore they have different feeling on the time their food arrives. Their feelings are measured by Displeasure Index. At the beginning, the Displeasure Index for each person is 0. When waiting for the food, the ith person will gain Bi Displeasure Index per minute.

If one's Displeasure Index goes too high, he will not buy your food any more. So you need to keep the sum of all people's Displeasure Index as low as possible in order to maximize your income. Your task is to find the minimal sum of Displeasure Index.

 

Input

 

The input contains multiple test cases, separated with a blank line. Each case is started with three integers N ( 1 <= N <= 1000 ), V ( V > 0), X ( X >= 0 ), then Nlines followed. Each line contains two integers Xi ( Xi >= 0 ), Bi ( Bi >= 0), which are described above.

You can safely assume that all numbers in the input and output will be less than 231- 1.

Please process to the end-of-file.

 

Output

 

For each test case please output a single number, which is the minimal sum of Displeasure Index. One test case per line.

 

Sample Input

 

5 1 0
1 1
2 2
3 3
4 4
5 5
 

 

Sample Output

 

55

题意:餐馆要给一条线上的所有人送饭,每个人都有一个距离,还有一个不满意值,随着时间的增长,每个人的不满意值也会增加,求怎样送饭可以使这些人的不满意值的和最小。

分析:将数组扩充为三维主要是为了描述是从i转移来还是由j转移来。

dp[i][j][k] 表示i->j区间内的最小不满意值,当k = 0表示停在i点,k = 1表示停在 j 点。

dp[i][j][0]可由dp[i + 1][j][0]、dp[i + 1][j][1]、dp[i][j -1][0]、dp[i][j - 1][1]转移来。

所以转移方程为:

dp[i][j][0] = min(dp[i][j][0],dp[i + 1][j][0] + (sum[i] - sum[j] + sum[n]) * (p[i + 1].x - p[i].x));
dp[i][j][0] = min(dp[i][j][0],dp[i + 1][j][1] + (sum[i] - sum[j] + sum[n]) * (p[j].x - p[i].x));
dp[i][j][1] = min(dp[i][j][1],dp[i][j - 1][0] + (sum[i - 1] - sum[j - 1] + sum[n]) * (p[j].x - p[i].x));
dp[i][j][1] = min(dp[i][j][1],dp[i][j - 1][1] + (sum[i - 1] - sum[j - 1] + sum[n]) * (p[j].x - p[j - 1].x)); 

sum【i】表示前i个人的不满意值之和;

 

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;

const int maxn = 1005;
const int INF = 0x3f3f3f3f;
int n,x,v;
int dp[maxn][maxn][2];
int sum[maxn];

struct node
{
    int x,b;
}p[maxn];

bool cmp(node a,node b)
{
    return a.x < b.x;
}

int main()
{
    while(cin >> n >> v >> x)
    {
        int tmp;
        for(int i = 1;i <= n;i ++)
        {
            cin >> p[i].x >> p[i].b;
        }
        n ++;
        p[n].x = x;
        p[n].b = 0;
        sort(p + 1,p + 1 + n,cmp);
        sum[0] = 0;
        for(int i = 1;i <= n;i ++)
        {
            sum[i] = sum[i - 1] + p[i].b;
        }
        for(int i = 1;i <= n;i ++)
        {
            if(p[i].x == x)
            {
                tmp = i;
                break;
            }
        }
        for(int i = 1;i <= n;i ++)
            for(int j = 1;j <= n;j ++)
            dp[i][j][0] = dp[i][j][1] = INF;
        dp[tmp][tmp][0] = dp[tmp][tmp][1] = 0;
        for(int i = tmp;i >= 1;i --)
            for(int j = tmp;j <= n;j ++)
        {
            if(i == j) continue;
            dp[i][j][0] = min(dp[i][j][0],dp[i + 1][j][0] + (sum[i] - sum[j] + sum[n]) * (p[i + 1].x - p[i].x));
            dp[i][j][0] = min(dp[i][j][0],dp[i + 1][j][1] + (sum[i] - sum[j] + sum[n]) * (p[j].x - p[i].x));
            dp[i][j][1] = min(dp[i][j][1],dp[i][j - 1][0] + (sum[i - 1] - sum[j - 1] + sum[n]) * (p[j].x - p[i].x));
            dp[i][j][1] = min(dp[i][j][1],dp[i][j - 1][1] + (sum[i - 1] - sum[j - 1] + sum[n]) * (p[j].x - p[j - 1].x));
        }
        cout << min(dp[1][n][0],dp[1][n][1]) * v << endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值