HDU1405(质因数分解)

题目:HDU - 1405 

Tomorrow is contest day, Are you all ready? 
We have been training for 45 days, and all guys must be tired.But , you are so lucky comparing with many excellent boys who have no chance to attend the Province-Final. 

Now, your task is relaxing yourself and making the last practice. I guess that at least there are 2 problems which are easier than this problem. 
what does this problem describe? 
Give you a positive integer, please split it to some prime numbers, and you can got it through sample input and sample output. 

Input

Input file contains multiple test case, each case consists of a positive integer n(1<n<65536), one per line. a negative terminates the input, and it should not to be processed.

Output

For each test case you should output its factor as sample output (prime factor must come forth ascending ), there is a blank line between outputs.

Sample Input

60
12
-1

Sample Output

Case 1.
2 2 3 1 5 1

Case 2.
2 2 3 1

        
  

Hint

60=2^2*3^1*5^1

        
 

输出真的太坑爹了,一直PE

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>

using namespace std;

const int maxn = 10005;
int prime[maxn];
void getprime()
{
    memset(prime,0,sizeof(prime));
    for(int i = 2;i <= maxn;i ++)
    {
        if(! prime[i]) prime[++ prime[0]] = i;
        for(int j = 1;j <= prime[0] && prime[j] <= maxn / i;j ++)
        {
            prime[prime[j] * i] = 1;
            if(i % prime[j] == 0) break;
        }
    }
}

int factor[100][2]; //factor[i][0]存底数,factor[i][1]存指数
int cnt;
void getFactors(int n) {
    cnt = 0;
    for(int i = 2; i <= n / 2; i++) {
        if(n % i == 0) {
            factor[cnt][0] = i;
            factor[cnt][1] = 0;
            while(n % i == 0) {
                factor[cnt][1]++;
                n /= i;
            }
            cnt++;
        }
    }
    if(n != 1) {
        factor[cnt][0] = n;
        factor[cnt][1] = 1;
        cnt++;
    }
}

int main()
{
    int n;
    int Case = 0;
    while(cin >> n && n > 0)
    {
        if(Case != 0) printf("\n");
        printf("Case %d.\n",++ Case);
        getFactors(n);
        for(int i = 0;i < cnt;i ++)
        {
            printf("%d %d ",factor[i][0],factor[i][1]);
        }
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值