“单身狗”是中文对于单身人士的一种爱称。本题请你从上万人的大型派对中找出落单的客人,以便给予特殊关爱。
输入格式:
输入第一行给出一个正整数N(<=50000),是已知夫妻/伴侣的对数;随后N行,每行给出一对夫妻/伴侣——为方便起见,每人对应一个ID号,为5位数字(从00000到99999),ID间以空格分隔;之后给出一个正整数M(<=10000),为参加派对的总人数;随后一行给出这M位客人的ID,以空格分隔。题目保证无人重婚或脚踩两条船。
输出格式:
首先第一行输出落单客人的总人数;随后第二行按ID递增顺序列出落单的客人。ID间用1个空格分隔,行的首尾不得有多余空格。
输入样例:
3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333
输出样例:
5
10000 23333 44444 55555 88888
分析:
详细代码:
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
// 1065 单身狗(25)(25 分) 没有完全通过
int main(void){
const int N = 100005;
int n1,n2;
int a[N]={0x00};
// input
cin>>n1;
for(int i=0;i<n1;++i){ // 00000 与 0 区别
int temp[2];
cin>>temp[0]>>temp[1];
++temp[0]; ++temp[1];
a[temp[0]] = temp[1];
a[temp[1]] = temp[0];
}
cin>>n2;
for(int i=0;i<n2;++i){
int temp; cin>>temp;
++temp;
if(a[temp] == 0){
a[temp] = -1;// 没有对肯定输出
}else{
a[temp] = 0;
}
}
//
int sum = 0;
for(int i=0;i<N;++i){
if(a[i]>0 && !a[a[i]]){
a[a[i]]=-1;
++sum; // 求对数
}
}
// 输出-1
cout<<(n2-sum)<<endl;
int x = 0;
for(int i=0;i<N;++i){
if(a[i]==-1){
if(++x == 1){
cout<<(i-1);
}else{
cout<<" "<<(i-1);
}
}
}
return 0;
}// jinzheng 2018.5.20 14:40
jinzheng