杭电ACM HDU 1142 A Walk Through the Forest

A Walk Through the Forest

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4249    Accepted Submission(s): 1543


Problem Description
Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable.
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take.


 

Input
Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections.


 

Output
For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647


 

Sample Input
  
  
5 6 1 3 2 1 4 2 3 4 3 1 5 12 4 2 34 5 2 24 7 8 1 3 1 1 4 1 3 7 1 7 4 1 7 5 1 6 7 1 5 2 1 6 2 1 0


 

Sample Output
  
  
2 4


 

Source


 

Recommend
Eddy

 

 

#include<cstdio>
#include<cstring>
#define FINITY 0x7fffffff
#define M 1005
int n;
int m[M][M];
int res[M],d[M];
void dijkstra(int v0){
    int fin[M];
    int i,j;
    int k,v=0,min;
    /**初始化*/
    for(v=0;v<n;v++){
        fin[v]=0;
        d[v]=m[v0][v];
    }
    fin[v0]=1;d[v0]=0;
    /**依次找出n-1个节点加入S*/
    for(i=1;i<n;i++){
        min=FINITY;
        for(k=0;k<n;k++){//找最小边节点
            if(!fin[k]&&d[k]<min){//!fin[k]表示k还在V-S中
                v=k;
                min=d[k];
            }
        }
        if(min==FINITY)return;
        fin[v]=1;//v加入S
        /**修改S与V-S中各节点的距离*/
        for(k=0;k<n;k++){
            if(!fin[k]&&m[v][k]!=FINITY&&(min+m[v][k]<d[k])){
                d[k]=min+m[v][k];
            }
        }
    }
}
/**记忆化搜索*/
int solve(int v){
    if(res[v])return res[v];//该点已经走过,返回:过该点有多少条路 
    if(v==1)return 1;//找到终点,返回1(1条路) 
    for(int i=0;i<n;i++)
        if(m[v][i]!=FINITY&&d[v]>d[i])
            res[v]+=solve(i);
    return res[v];//返回:该点一共可以有多少条路 
}

int main(){
    int i,j,t;
    int d[M];
    int x,a,b,c,max[M],Min;
    while(~scanf("%d%d",&n,&x)&&n){
        memset(res,0,sizeof(res));
        for(i=0;i<n;i++)
            for(j=0;j<n;j++)
                m[i][j]=FINITY;
        for(i=0;i<x;i++){
            scanf("%d%d%d",&a,&b,&c);
            m[b-1][a-1]=m[a-1][b-1]=c;
        }
        dijkstra(1);
        printf("%d\n",solve(0));
    }
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值