杭电ACM HDU 3105 Fred's Lotto Tickets

Fred's Lotto Tickets

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 530    Accepted Submission(s): 352


Problem Description
Fred likes to play the lotto. Whenever he does, he buys lots of tickets. Each ticket has 6 unique numbers in the range from 1 to 49, inclusive. Fred likes to ``Cover all his bases." By that, he means that he likes for each set of lottery tickets to contain every number from 1 to 49, at least once, on some ticket. Write a program to help Fred see of his tickets ``Cover all the bases."


 

Input
The input file consists of a number of test cases. Each case starts with an integer N ( 1<=N<=100 ), indicating the number of tickets Fred has purchased. On the next N lines are the tickets, one per line. Each ticket will have exactly 6 integers, and all of them will be in the range from 1 to 49 inclusive. No ticket will have duplicate numbers, but the numbers on a ticket may appear in any order. The input ends with a line containing only a `0'.


 

Output
Print a list of responses for the input sets, one per line. Print the word `Yes' if every number from 1 to 49 inclusive appears in some lottery ticket in the set, and `No' otherwise. Print these words exactly as they are shown. Do not print any blank lines between outputs.


 

Sample Input
  
  
1 1 2 3 4 5 6 9 1 2 3 4 5 6 10 9 8 7 12 11 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 19 34 27 25 13 0


 

Sample Output
  
  
No Yes


 

Source


 

Recommend
gaojie

 

 

#include <stdio.h>
int main(){
    int n,i,a;
    int f[50];
    while(scanf("%d",&n),n){
        for(i=0;i<50;i++)
            f[i]=0;
        for(i=0;i<n*6;i++){
            scanf("%d",&a);
            f[a]=1;
        }
        for(i=1;i<50;i++)
            if(f[i]==0)i=60;
        printf("%s\n",i>55?"No":"Yes");
    }
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值