10474 - Where is the Marble?

Uva

10474 - Where is the Marble?


 Where is the Marble? 

Raju and Meena love to play with Marbles. They have got a lotof marbles with numbers written on them. At the beginning, Rajuwould place the marbles one after another in ascending order ofthe numbers written on them. Then Meena would ask Raju tofind the first marble with a certain number. She would count1...2...3. Raju gets one point for correct answer, and Meena getsthe point if Raju fails. After some fixed number of trials thegame ends and the player with maximum points wins. Today it'syour chance to play as Raju. Being the smart kid, you'd be takingthe favor of a computer. But don't underestimate Meena, she hadwritten a program to keep track how much time you're taking togive all the answers. So now you have to write a program, whichwill help you in your role as Raju.

Input 

There can be multiple test cases. Total no of test cases is less than 65. Each test case consistsbegins with 2 integers:N the number of marbles andQ the number of queries Mina wouldmake. The nextN lines would contain the numbers written on theN marbles. These marblenumbers will not come in any particular order. FollowingQ lines will haveQ queries. Beassured, none of the input numbers are greater than 10000 and none of them are negative.

Input is terminated by a test case where N = 0 andQ = 0.

Output 

For each test case output the serial number of the case.

For each of the queries, print one line of output. The format of this line will depend uponwhether or not the query number is written upon any of the marbles. The two different formatsare described below:

  • `x found at y', if the first marble with numberx was found at positiony.Positions are numbered1, 2,...,N.
  • `x not found', if the marble with numberx is not present.

Look at the output for sample input for details.

Sample Input 

4 1
2
3
5
1
5
5 2
1
3
3
3
1
2
3
0 0

Sample Output 

CASE# 1:
5 found at 4
CASE# 2:
2 not found
3 found at 3



Problem-setter: Monirul Hasan Tomal, Southeast University
题目大意:
给出N个序列,Q个提问,求提问中给出的数字在N序列升序排序后最早出现的位置;

以下给出两种方法:
1、先排序,后折半查找

#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
int binarysearch(int *a,int n,int p)
{
    int f=0,e=n-1,ans=-1;
    while(f<=e)
    {
        int mid=(e+f)/2;
        if(p<=a[mid])//这WA了一次,忘了有重复数字,查找到最靠前的那个;
        {
            if(a[mid]==p)//忘加判断WA了一次;
                ans=mid;
            e=mid-1;//忘了-1(后面忘了+1),出现无限循环;
        }
        else
            f=mid+1;
    }
    return ans;
}
int main()
{
//    freopen("a.txt","r",stdin);
    int n,q,a[10000],cas=0;
    while(cin>>n>>q&&n&&q)
    {
        for(int i=0;i<n;i++)
            cin>>a[i];
        sort(a,a+n);
        cout<<"CASE# "<<++cas<<':'<<endl;
        for(int i=0;i<q;i++)
        {
            int b;
            cin>>b;
            int m=binarysearch(a,n,b)+1;
            if(m)
                cout<<b<<" found at "<<m<<endl;
            else
                cout<<b<<" not found"<<endl;
        }
    }
    return 0;
}

2、计数排序

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int main()
{
//    freopen("a.txt","r",stdin);
    int n,q,a[10003],cas=0;
    while(cin>>n>>q&&n&&q)
    {
        int maxn=0,tmp;
        memset(a,0,sizeof(a));
        for(int i=0;i<n;i++)
        {
            cin>>tmp;
            a[tmp]++;//a[tmp]记录tmp出现的个数;
            maxn=max(tmp,maxn);//最大出现的数;
        }
        tmp=0;
        for(int i=1;i<=maxn;i++)
            if(a[i])
            {
                tmp+=a[i];
                a[i]=tmp-a[i]+1;//a[i]现在记录为i最早出现的位置;
            }
        cout<<"CASE# "<<++cas<<':'<<endl;
        for(int i=0;i<q;i++)
        {
            int b;
            cin>>b;
            if(a[b])
                cout<<b<<" found at "<<a[b]<<endl;
            else
                cout<<b<<" not found"<<endl;
        }
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值