10420 - List of Conquests

Uva

10420 - List of Conquests

Problem B
List of Conquests
Input:
standardinput
Output:
standard output
Time Limit:
2 seconds

In Act I, Leporello is tellingDonna Elvira about his master's long list of conquests:

``This is the list of the beauties my master has loved,a list I've made out myself: take a look, read it with me. In Italy six hundredand forty, in Germany two hundred and thirty-one, a hundred in France,ninety-one in Turkey; but in Spain already a thousand and three! Among them arecountry girls, waiting-maids, city beauties; there are countesses, baronesses,marchionesses, princesses: women of every rank, of every size, of every age.''(Madamina, il catalogo è questo)

AsLeporello records all the ``beauties'' Don Giovanni ``loved'' in chronological order,it is very troublesome for him to present his master's conquest to othersbecause he needs to count the number of ``beauties'' by their nationality eachtime. You are to help Leporello to count.

Input

Theinput consists of at most 2000lines, but the first. The first line contains a number n, indicating that there will be nmore lines. Each following line, with at most 75 characters, contains a country (the first word) and the name ofa woman (the rest of the words in the line) Giovanni loved. You may assume thatthe name of all countries consist of only one word.

Output

Theoutput consists of lines in alphabetical order. Each line starts with the nameof a country, followed by the total number of women Giovanni loved in thatcountry, separated by a space.

Sample Input

3
Spain Donna Elvira
England Jane Doe
Spain Donna Anna

Sample Output

England 1

Spain 2


Problem-setter:Thomas Tang, Queens University, Canada

 

 

“Failure to produce a reasonably good and error freeproblem set illustrates two things a) Lack of creativity b) Lack of commitment”

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
using namespace std;
int cmp(const void* a,const void* b)
{
    return strcmp((char *)a,(char *)b);
}
int main()
{
//    freopen("a.txt","r",stdin);
    int n;
    char c[2000][80];
    cin>>n;
    getchar();
    for(int i=0;i<n;i++)
    {
        char s[80];
        fgets(s,80,stdin);

        int j;
        for(j=0;(c[i][j]=s[j])!=' ';j++);
        c[i][++j]='\0';
    }
    qsort(c,n,80*sizeof(char),cmp);
    int num=1;
    for(int i=1;i<n;i++)
    {
        if(strcmp(c[i-1],c[i])==0)
            num++;
        else
        {
            cout<<c[i-1]<<num<<endl;
            num=1;
        }
    }
    cout<<c[n-1]<<num<<endl;
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值