描述:
Anniversary party
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 5516 | Accepted: 3164 |
Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0
Output
Output should contain the maximal sum of guests' ratings.
Sample Input
7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0
Sample Output
5
Source
题意:
某公司要举办一次晚会,但是为了使得晚会的气氛更加活跃,每个参加晚会的人都不希望在晚会中见到他的直接上司,现在已知每个人的活跃指数和上司关系(当然不可能存在环),求邀请哪些人(多少人)来能使得晚会的总活跃指数最大。
思路:
任何一个点的取舍可以看作一种决策,那么状态就是在某个点取的时候或者不取的时候,以他为根的子树能有的最大活跃总值。分别可以用dp[i,1]和dp[i,0]表示第i个人来和不来。
当i来的时候,dp[i][1] += dp[j][0];//j为i的下属
当i不来的时候,dp[i][0] +=max(dp[j][1],dp[j][0]);//j为i的下属
代码:
#include <cstdio>
#include <cstring>
#include <algorithm>
#define mst(ss,b) memset(ss,b,sizeof(ss));
using namespace std;
const int N=6005;
int n;
int dp[N][2],father[N];//dp[i][0]0表示不去,dp[i][1]1表示去了
int vis[N];
void dfs(int node){
vis[node]=1;
for(int i=1; i<=n; i++){
if(!vis[i] && father[i]==node){
dfs(i);
dp[node][1]+=dp[i][0]; //node去,则i必不能去
dp[node][0]+=max(dp[i][0], dp[i][1]); //node不去,取i去或不去的最大值
}
}
}
int main(){
int rt,l,k;
while(~scanf("%d",&n)){
mst(dp, 0);
mst(father, 0);
mst(vis, 0);
for(int i=1; i<=n; i++)scanf("%d",&dp[i][1]);
rt=0;//记录父结点
while(~scanf("%d %d",&l,&k),l||k){
father[l]=k; //记录上司
rt=k;
}
dfs(rt);
printf("%d\n",max(dp[rt][1], dp[rt][0]));
}
return 0;
}
PS:第一次写树形dp,以前总感觉只要和树扯上关系的就很麻烦,一直没去了解树形dp,今天想尝试一下,发现其实也没有想象中的那么麻烦,也就是用题目给出的关系建立一颗关系树,其实难点在建树和状态转移方程上。